Any Idea Why New Solar System Might Not Be Charging.? (1 Viewer)

Apr 11, 2015
5,499
56,431
hull
Funster No
35,812
MH
Laika Ecovip 300
Exp
since 1988 with breaks until 2009
We had 2x60ah solar panels fitted by dealer before we got the Mizar. Over weekend were on hook up, which doesn't charge vehicle battery. Despite bright sunshine for 3 days the vehicle battery was not fully charged, system is not fully charging the new leisure battery either. Any ideas of what we can check before taking it back again ? Will look at the make tomorrow oops might be today.
 

BwB

LIFE MEMBER
Apr 3, 2011
917
1,170
Suffolk UK
Funster No
15,893
MH
Resting b'twix vans
Exp
Since 1990
Probably only set up to charge the habitation batteries. Not unusual.

Simplest fix is to install a Battery Master (see the shop on this website) to install yourself or get your dealer to install one (or contact eddievanbitz member on this site who will take care or it for you.
 

funflair

LIFE MEMBER
Dec 11, 2013
19,555
31,259
Guisborough
Funster No
29,351
MH
MORELO palace
Exp
since 2012
You say that it also doesn't fully charge the leisure battery either, is it charging at all, what voltage does the leisure battery show with sun on the panels and do you have an amp meter telling you what is going in and out. Also worth checking that the controller for the solar is et for the correct battery type.

I agree that it is probably not hooked up the the engine battery as well as leisure.
 

Jim

Ringleader
Jul 19, 2007
36,722
132,873
Sutton on Sea, UK
Funster No
1
MH
Adria Panel Van.
Exp
Since 1988
At this time of year, very often solar panels cannot hope to fully charge your battery/ies. There is just not enough sun and when we have it its at a low angle. Most van setups do not have in place provision to charge the engine battery. That is why we sell these http://shop.motorhomefun.co.uk/product/battery-master/

When your leisure battery is full, via mains hookup or Solar it diverts some charge to your engine battery to keep it topped up (y)
 
Oct 30, 2010
4,256
20,709
Suffolk or France or ........
Funster No
14,290
MH
A Class Carthago Chic
Exp
Since 2008
Had the same problem on my brand new Carthago.
As we were going to Vanbitz anyway we had them fit a Battery Master which seems to have sorted the vehicle battery charging.
Solar is still not charging however and the dealers had a look last Friday and found that there is a fault in the factory installed wiring that they had hooked the panels up to. Problem is the wiring loom runs behind the fridge/freezer which has to be taken out to investigate further. Hopefully it will be sorted next week when we go back to the other side of the country.

Richard.

Subscribers  do not see these advertisements

 
OP
OP
scotzsue
Apr 11, 2015
5,499
56,431
hull
Funster No
35,812
MH
Laika Ecovip 300
Exp
since 1988 with breaks until 2009
This is our second van first had 80W solar which fully charged both batteries, even in very poor weather. When we bought this one we arranged to have 1 larger solar panel fitted, but not enough room so got 2 smaller ones to give same output. It is set up for both batteries, state of charge lights indicate that both are being charged, know that the vehicle battery is probably the original and may be on its way out but solar is not even keeping level even.there is a toad alarm fitted which will be a drain on the battery, but would have thought input would be sufficient for levels not to fall.
Shouldnt compare i know but we manged 5 days off hook up over new year 85AH battery and 80W solar, no probems at all. (previous van) will be looking at connections later if weather holds up, well John will, unless golf interferes.
 
OP
OP
scotzsue
Apr 11, 2015
5,499
56,431
hull
Funster No
35,812
MH
Laika Ecovip 300
Exp
since 1988 with breaks until 2009
Probably only set up to charge the habitation batteries. Not unusual.

Simplest fix is to install a Battery Master (see the shop on this website) to install yourself or get your dealer to install one (or contact eddievanbitz member on this site who will take care or it for you.
.Is not charging at all neither leisure nor vehicle battery, set up to charge both, at least it should be
 
OP
OP
scotzsue
Apr 11, 2015
5,499
56,431
hull
Funster No
35,812
MH
Laika Ecovip 300
Exp
since 1988 with breaks until 2009
Should say it does not top the batteries up fully, am not expecting solar to fully recharge a discharged battery, leisure battery is new. More solar power now than before, batteries losing charge when parked up. Does have a toad alarm, but everything else is switched off. Solar was more than capable of keeping both batteries topped up summer and winter on last system. going in soon for a check.
 

Baggers53

Free Member
Dec 30, 2013
187
221
Stafford
Funster No
29,491
MH
C Class
Exp
2013
I fitted a 100W solar panel to my Bessacarr MH. The manual stated wiring loom in place to use input from a solar panel and regulator.
Well this, when wired up did not work, the connection to the negative on the leisure battery was fine, the positive connection was not.
I hard wired my own connections to both battery terminals and all worked fine.

Subscribers  do not see these advertisements

 
OP
OP
scotzsue
Apr 11, 2015
5,499
56,431
hull
Funster No
35,812
MH
Laika Ecovip 300
Exp
since 1988 with breaks until 2009
I fitted a 100W solar panel to my Bessacarr MH. The manual stated wiring loom in place to use input from a solar panel and regulator.
Well this, when wired up did not work, the connection to the negative on the leisure battery was fine, the positive connection was not.
I hard wired my own connections to both battery terminals and all worked fine.

Thanks for that, was thinking this might be a possibility, have had another 3 days on hook up whilst away, will go to storage to see how things are.
 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top