lost all hab power (1 Viewer)

Affiliate links here may earn MHF compensation
Nov 18, 2011
11,945
44,518
Planet Earth
Funster No
18,938
MH
A van
Exp
Over 25 year's
20141102_140517.jpg
hi we seem to have lost all hab power the battery's are fine thought they were knackered but had multy meter set wrong.
there is power going to the board controller but it dose not seem to light up thinking it has dyed
 
D

Deleted member 29692

Deleted User
Is there a fuse somewhere protecting it?
 

TheBig1

LIFE MEMBER
Nov 27, 2011
17,800
44,227
Dorset
Funster No
19,048
MH
A class
Exp
many many years! since I was a kid
check at the switch on the board. if you get power through from engine battery, its either a bad connector on the wiring from leisure battery or battery itself dropping under load
 
OP
OP
Wildbill
Nov 18, 2011
11,945
44,518
Planet Earth
Funster No
18,938
MH
A van
Exp
Over 25 year's
check at the switch on the board. if you get power through from engine battery, its either a bad connector on the wiring from leisure battery or battery itself dropping under load
I have 12.9v at zig unit

Subscribers  do not see these advertisements

 
OP
OP
Wildbill
Nov 18, 2011
11,945
44,518
Planet Earth
Funster No
18,938
MH
A van
Exp
Over 25 year's
I have had problems with this from time to time wondering if I should just re wire the hab aria of the van only x six lights water pump and fire fan and just have every thin on fuses
bill
 

TheBig1

LIFE MEMBER
Nov 27, 2011
17,800
44,227
Dorset
Funster No
19,048
MH
A class
Exp
many many years! since I was a kid
on which wire bill, the leisure or the engine battery? does the 12.9v appear on the output of the switch?
 

TheBig1

LIFE MEMBER
Nov 27, 2011
17,800
44,227
Dorset
Funster No
19,048
MH
A class
Exp
many many years! since I was a kid
it should be an easy(ish ) fix if its a dry joint or bad switch
 
OP
OP
Wildbill
Nov 18, 2011
11,945
44,518
Planet Earth
Funster No
18,938
MH
A van
Exp
Over 25 year's
I now have power to the hab aria but the zig controller dose not light up or switch over from bat 1 to bat 2
 

TheBig1

LIFE MEMBER
Nov 27, 2011
17,800
44,227
Dorset
Funster No
19,048
MH
A class
Exp
many many years! since I was a kid
i would suggest its a bad switch then bill

dry joint is a solder joint that has failed and needs resoldering
 
OP
OP
Wildbill
Nov 18, 2011
11,945
44,518
Planet Earth
Funster No
18,938
MH
A van
Exp
Over 25 year's
i would suggest its a bad switch then bill

dry joint is a solder joint that has failed and needs resoldering
I have had problems with this and the transformer for a while I have disconnected the trans former and fitted a maintenance battery charger
as I cant get hold of a trans former
 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top