Thetford fridge problem (1 Viewer)

Affiliate links here may earn MHF compensation

Peter Adams

Free Member
Apr 1, 2019
4
0
Funster No
59,519
MH
C
Exp
1999
Hi all. I have a 2010 Thetford 3way fridge ( can't see which model it is unfortunately). It ignites on gas ok ,runs for about an hour and then stops and shows fault 9. It wont then re ignite even by turning it off and on again. If I leave it a while, presumably till it cools down it will then re ignite once turned off and on again. It then goes fine until the same thing happens ,every time. Anyone had this and know what is wrong?
 
Apr 27, 2016
7,026
8,233
Manchester
Funster No
42,762
MH
A class Hymer
Exp
Since the 80s
The model number is usually on an inconspicuous label inside the fridge.

Does the problem happen when it's working on mains electricity? If it works OK on mains, then it's a gas problem.

Maybe it just needs a service - the gas jet may be a bit blocked, the flue may be restricted etc. or maybe the flame failure electrodes are not correctly positioned, or if it has a thermocouple it may have failed.
 

Jaws

LIFE MEMBER
Sep 26, 2008
23,868
73,744
Thetford Norfolk
Funster No
4,189
MH
C class, Chieftain
Exp
since 2006 ( I think ! )
Hi all. I have a 2010 Thetford 3way fridge ( can't see which model it is unfortunately). It ignites on gas ok ,runs for about an hour and then stops and shows fault 9. It wont then re ignite even by turning it off and on again. If I leave it a while, presumably till it cools down it will then re ignite once turned off and on again. It then goes fine until the same thing happens ,every time. Anyone had this and know what is wrong?
Make sure the flue is clear.. That was one of the early problems we had shortly after collecting the ( 2n hand ) van from the dealer
 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top