Fridge help please

Discussion in 'Motorhome Chat' started by Forester, Jul 16, 2014.

  1. Forester

    Forester

    Joined:
    May 21, 2012
    Messages:
    161
    Location:
    forest of dean
    Ratings:
    +186
    Leaving Sunday for a couple of weeks Germany and France as normal something has to go wrong at the last minute. Used the van at w/e and fridge (Thetford) rean on gas but was smelly and the vent sooted up. I took the flame valve/tube out it was very clogged up with carbon and I am amazed it ran at all. Also looks as ik someone has tried to take the valve out and distorted the tube in the process. After cleaning out I tried to start the fridge, It fires up immeadiately but goes out as soon as I let the button go and the igniter can be hesrd sparking continually. I bought a new valve/tube today replaced the old one but exactly the same. Fridge runs perfectly on mains hook up. What do I do next?
     
  2. eric 83

    eric 83

    Joined:
    Jan 6, 2009
    Messages:
    90
    Location:
    leeds
    Ratings:
    +46
    Sounds like the thermo coupler is not in the heat enough and not opening the gas valve
     
    • Like it Like it x 1
  3. Forester

    Forester

    Joined:
    May 21, 2012
    Messages:
    161
    Location:
    forest of dean
    Ratings:
    +186
    Thank you so much. I just took it apart again moved the thermocouple a little and lo and behold fridge works a treat on gas.
    Sir you are a star, thanks again:)
     
  4. camocam1

    camocam1

    Joined:
    Aug 28, 2012
    Messages:
    1,112
    Location:
    Elgin,Moray,Scotland
    Ratings:
    +784
    Result that's what I like about this forum
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice