Eldis Autostratus 2000, various problems

Discussion in 'Motorhome Help for the Beginner' started by mhmaddog23, May 31, 2009.

  1. mhmaddog23

    mhmaddog23

    Joined:
    May 31, 2009
    Messages:
    9
    Location:
    Zumerzet
    Ratings:
    +3
    Thanks for reading: Divorce has left me with the camper, but not the funds to have a dealer repair it.....

    >I believe I need new gas(?) struts for my Heiki roof window - where's the best place to buy them?

    >The two directional roof-mounted air extractor has stopped working, anyone know if there are fuses anywhere or can I just drop a new motor unit from the top - where would I buy one

    > Three way fridge, the green (mains) and gas "on" lights both work, but the little red light (battery) does not illuminate. Is this likely to be a blown bulb, or perhaps suggest that the fridge doesn't work when switched to "battery". It does stay a little cooler, but not very!

    > the small bind over the sink - one of the ratchet rods has come loose from the centre handle (you squeeze the handle to move the rods inwards so the blind will lift) - it doesn't look like it's easily repairable (?) so where might I get a new blind (the blind not the flyscreen) and is it fairly simple to fix.

    Cheers

    Martin
     
    Last edited: May 31, 2009
  2. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    34,245
    Location:
    YO11 2BD
    Ratings:
    +30,980
    hi and welcome to the FUN....


    only thing i can help with is the fridge.

    do you mean the 12v doesnt light when running the engine or when you are pitched?

    it only lights when the engine is running, not designed to light when on site.

    the rods in the blinds are fixable but i'v not done one so not sure how.
     
  3. Brisey

    Brisey Funster Life Member

    Joined:
    Sep 4, 2007
    Messages:
    8,019
    Location:
    Tropical Bar,Benidorm.
    Ratings:
    +19,462
    Hi Martin

    > Three way fridge, the green (mains) and gas "on" lights both work, but the little red light (battery) does not illuminate. Is this likely to be a blown bulb, or perhaps suggest that the fridge doesn't work when switched to "battery". It does stay a little cooler, but not very!

    Your fridge should only work on 12volts when the engine is running.
     
  4. mhmaddog23

    mhmaddog23

    Joined:
    May 31, 2009
    Messages:
    9
    Location:
    Zumerzet
    Ratings:
    +3
    Hi PJ Thanks. The answer is - it doesn't light when the engine is running....
    Cheers
    Martin
     
  5. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    34,245
    Location:
    YO11 2BD
    Ratings:
    +30,980
    it could be the bulb but its more likely to be the relay controlling the fridge if it doesnt seem to get very cold.
    its usually near the engine battery along with the charge relay for the leisure battery.
    usually just a regular square relay....give it a tap with the engine running and see if the light comes on.
    if not you'll need a voltmeter to check the relay output first then work your way back to the fridge checking for power.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice