Ec 840 Woes (1 Viewer)

Nik

Oct 29, 2014
359
238
Cornish exile in Surrey
Funster No
34,038
MH
Autotrail Delaware
Exp
1 year
Hi.
My EC840 display in my Autotrail has frozen at 0855, it's now 2220. We had a power EHU problem and the system went off. Having turned things back on the display is now frozen and I cant change anything. I cant get to the Autotrail logo to try a reset. I have switched everything off and gradually brought power back to the various systems. My ec500 unit seems ok having done the initial test following hookup. Water, heating, lights, water pump are working ok but I can't get any electric/water ' level bar graphs'. I just get a beep when I press any of the buttons on the right of the display.
Any advice grateful received.
Best regards.
Nik
 

Gellyneck

LIFE MEMBER
Jun 5, 2014
9,503
19,052
Scotland
Funster No
31,836
MH
C Class
Exp
More than toes wet now!
Have you tried doing a full system shutdown or holding down up \ down buttons until the Dealer Setting menu comes up?
 
Feb 8, 2014
1,665
4,693
Sheffield
Funster No
30,022
MH
Eldis Majestic 115
Exp
Vans and tugs since mid 70's
Try disconnecting EHU then full shutdown ec500, wait 5mins then power up ec500?
 
OP
OP
Nik

Nik

Oct 29, 2014
359
238
Cornish exile in Surrey
Funster No
34,038
MH
Autotrail Delaware
Exp
1 year
Thanks both.
I have tried pressing and holding the control buttons, it beeps but nothing else happens. I will again try a full disconnect and shutdown a bit later when it stops raining here in Sunny? Hastings.
Thanks again.
Nik
 

mike mcglynn

LIFE MEMBER
Deceased RIP
Jan 6, 2008
2,700
32,552
St. Helens MERSEYSIDE
Funster No
1,144
MH
Autosleeper Warwick XL
Exp
A long time now
Hi. Nic in my autotrail when the control panel freezes up I disconnect it from the power for a few minutes 2 small screws and a plug to come off let it rest for a few minutes and when you put it back together you should hear a little beep then everthing goes back to normal.

Subscribers  do not see these advertisements

 

Jaws

LIFE MEMBER
Sep 26, 2008
23,854
73,088
Thetford Norfolk
Funster No
4,189
MH
C class, Chieftain
Exp
since 2006 ( I think ! )
If all else fails, click the front bezel off, remove the screws that hold the panel in place, and gently pull the main plug out of the panel
leave on the side for a while, then refit
 

Gellyneck

LIFE MEMBER
Jun 5, 2014
9,503
19,052
Scotland
Funster No
31,836
MH
C Class
Exp
More than toes wet now!
If all else fails, click the front bezel off, remove the screws that hold the panel in place, and gently pull the main plug out of the panel
leave on the side for a while, then refit
Would the shutdown mode on the main panel not achieve same, John?:unsure: Dealer told us it powered down everything except the alarm \ tracker but would believe a man who's disconnected and recollected every wire with enough left over for, eh......., over them.:)
 

Jaws

LIFE MEMBER
Sep 26, 2008
23,854
73,088
Thetford Norfolk
Funster No
4,189
MH
C class, Chieftain
Exp
since 2006 ( I think ! )
No mate.. It would if the thing had not locked up but with the wee processor all baffled it is unlikely

Some panels also have a button battery ( mine has not but a lot do ! ) if you have a button battery hook that out too !
 
OP
OP
Nik

Nik

Oct 29, 2014
359
238
Cornish exile in Surrey
Funster No
34,038
MH
Autotrail Delaware
Exp
1 year
Hi All.
Turned it all of, drove up to Bodiham Castle for a few hours and when arrived back on site turned all back on and hey presto all appears ok for now and back to normal.

Thanks all for your help,panic over.
Cheers.
Nik

Subscribers  do not see these advertisements

 
Feb 8, 2014
1,665
4,693
Sheffield
Funster No
30,022
MH
Eldis Majestic 115
Exp
Vans and tugs since mid 70's
That's good news Nik, will remember fix for future:)
 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top