Dometic gas problems (1 Viewer)

Affiliate links here may earn MHF compensation
Oct 7, 2013
5,972
37,552
South Wales
Funster No
28,463
MH
Swift Escape Compact
Exp
Since 1988
Sorry, posted this elsewhere on forum before spotting this section.

While away last week we found our fridge in our 2007 Swift Sundance was not getting cold when operating on gas.

On pressing the piezo ignition the indicator needle moves into the green and heat can be felt issuing from the exhaust so it appears that the gas is lighting OK. However, there is no cooling effect at all, (checked with thermometer in freezer compartment).

On mains or battery all is well.

Any suggestions as to what is causing the problem, or ways to fix it would be much appreciated.
 

Millibobs

Free Member
Oct 27, 2013
101
21
Sax Alicante area Spain
Funster No
28,762
MH
Overcab
Exp
Since 2004
Hola try blowing the igniter jet on the gas supply and clear the holes out. It may be that although it lights it just isn't a big enough flame to get the fridge cold.
Took mine to a Dometic agent in Alicante two weeks ago and that's all he did to get mine working ok.
 

Millibobs

Free Member
Oct 27, 2013
101
21
Sax Alicante area Spain
Funster No
28,762
MH
Overcab
Exp
Since 2004
I would think so but the spanish guy did mine out on the street whilst I watched. Suren it wasnt level cos I was parked in a parking slot. Im no expert but I will know next time
 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top