Alde Touch Panel Failure (1 Viewer)

Affiliate links here may earn MHF compensation

zac

LIFE MEMBER
Nov 19, 2013
2,645
1,904
Basingstoke
Funster No
29,076
MH
Rapido A CLass 10000
Exp
since 2013
Ordered another Alde 3020 touch control panel this week as the one i have is not "iNet Ready" so cannot connect the iNet box to it. On receiving the panel and plugging it in after approx 30seconds it would display "Panel Failure". The heating would still work but the red light would come on and 2 yellow triangles would appear. A quick call to Alde and they advised that it is either moisture in the control panel or it is faulty. So first night i left it on top of our wooden radiator surround but this didnt work as same error the next day. So i thought i would leave it in the airing cupboard overnight and try one last time before sending it back. Well after setting the phone up to record the error so i could prove the fault i powered it on and to my amazement it is now working. So anyone else sees this particular fault then leave somewhere warm over night. No idea how moisture got in to the screen but i have now left it on to see if the error comes back but all signs look good so far.

Alde technical support was good as well as now i have booked my fluid change with them they said that if the error was still there when i arrive they will sort this as well which was nice of them.
 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top