6.2 chevy charging problem

Alegro88

Free Member
Joined
Sep 13, 2008
Messages
4
Location
Swindon, Wiltshire
MH
A Class
Exp
3
Dear All
My allegro 1988 6.2l diesel
When started the charge seems ok but whilst running the charge drops to almost 8volts. It doesnt charge the battery but it does still run ok which is strange as i would expect it to stop if just running on the battery?
I then need to use the rear generator to charge the battery and start it again
Any advice freatly recieved.

Chris
 

PeteH

Funster
Joined
Nov 22, 2007
Messages
3,989
Location
East Yorkshire
MH
Rapido "A" Class, Mecedes
Exp
18+yrs plus 25+Towing
Lack of charge

Hi

How are you measuring the output? You really need a good Digital multimeter across the Alternator to a good "earth", a charge of less than "Battery Voltage" (nominally 12v) would indicate an alternator problem. a "good" alternator will produce 13 to 15 Volts dependant of battery state. If it`s the same configuration as my pace arrow was (6.2 diesel) the "fan" belt also drives the Air-Con. and was prone to slip badly reducing the alternator speed. and could part company without loss of other functions (P.A.S) etc which had separate belt(s). One indication of a broken belt is a light on the dash (poss Orange or red) when the engine is running.

pete
 
SMC Motorhomes Newark
RoadPro
Johns Cross
Safeguard Motorhome Insurance
Rhino Installs
Friendly professional service from qualified technicians
Free Club Stickers
Dave Newell Leisure Vehicle Services
Top