Morning all

Discussion in 'Motorhome Chat' started by wardy, Feb 2, 2010.

  1. wardy

    wardy Read Only Funster

    Joined:
    Feb 1, 2010
    Messages:
    4
    Likes Received:
    0
    Is there anyone out there who could help me? I have an electrical problem with my motorhome (Riviera) which I just cant sort out. So if you know of a good auto electrician in the Southampton /Portsmouth area perhaps you could let me know. Cheers.
     
  2. ourcampersbeentrashed

    ourcampersbeentrashed Funster

    Joined:
    Apr 19, 2008
    Messages:
    7,652
    Likes Received:
    4,284
    Location:
    East London
    Hi and Welcome to fun - Im in London so too far away however

    some local councils have their own MOT stations the public can use, some even offer a repair service, so give yours a ring - our local council sorted out our mh a treat so give yours ring, they may be able to help or point you in the right direction if no other mhfunsters can give you a recommendation


    Good luck hope you get it sorted soon
     
  3. hilldweller

    hilldweller Funster Life Member

    Joined:
    Dec 5, 2008
    Messages:
    26,473
    Likes Received:
    25,165
    Location:
    Macclesfield
    Well you could try describing it.

    You'll get ten maybe twenty replies. Most of them will be totally wrong or off subject but you may just get one good one.
     
  4. Johns_Cross_Motorhomes

    Johns_Cross_Motorhomes Trader - Motorhome & Accessory Sales

    Joined:
    Jan 5, 2008
    Messages:
    9,248
    Likes Received:
    5,199
    Location:
    East Sussex 01-580-881288
    Hi Wardy,

    It does help if you post what the problem is.

    Peter
     
  5. wardy

    wardy Read Only Funster

    Joined:
    Feb 1, 2010
    Messages:
    4
    Likes Received:
    0
    Electrical Problem

    Cheers, Brian, sounds like that might be worth a go.

    I have a 1994 Ford Transit Riviera (imported, left-hand drive). When I plug the mains in I get a constant ticking from the consumer unit. The red light shows the 12 volts appears to be charging but it continually flashes in time with the 'ticking'. The only thing that seems to stop the ticking is turning on the main light in living area. Beats me! :Rofl1:
    Anyone got any ideas?

    Many thanks
     
Loading...

Share This Page