Indicators

Discussion in 'Tech/Mech General' started by bandit, Dec 9, 2011.

  1. bandit

    bandit Funster

    Joined:
    Oct 2, 2011
    Messages:
    221
    Likes Received:
    112
    Location:
    Widnes,Cheshire
    Evenin all,got a small problem,my indicators av stopped working,left and right.But my hazards are working.I think the indicator stalk might be goosed,but i dont know.Also does anybody know where the indicator relay is.Swift Kontiki 2.5 Talbot,[ Jreg ]hopefully somebody might av more knowledge than me. THX THE BANDIT :thumb:
     
  2. stagman

    stagman Deleted User

    If you listen out for the hazard relay you might find the indicator relay close by :thumb:
     
  3. Craig Rogers

    Craig Rogers Read Only Funster

    Joined:
    Nov 9, 2011
    Messages:
    651
    Likes Received:
    411
    Location:
    Midlands, UK (Welsh!)
    Plus the indicator relay may be on a different fuse to the hazard relay, so have a look at your fuse box.
     
  4. aba

    aba

    Joined:
    Oct 27, 2009
    Messages:
    2,793
    Likes Received:
    1,119
    Location:
    yorkshire
    if the hazard switch is playing up at all it can stop the indicators from working.
    best have the indicators on and wiggle and press the hazard switch a bit but not all the way in and see if that helps.

    normally the hazard relay is the same as the indicator one.
     
  5. bandit

    bandit Funster

    Joined:
    Oct 2, 2011
    Messages:
    221
    Likes Received:
    112
    Location:
    Widnes,Cheshire
    thx andy

    Hi Andy,im goin 2 av a look 2morrow,and try doin some of the ideas.I think this site is very good,i have asked for help and its all ways forth coming.So thx for your imput.:thumb:
     
Loading...
Similar Threads
  1. 2bob
    Replies:
    16
    Views:
    383

Share This Page