Thetford N150 Fault (1 Viewer)

Affiliate links here may earn MHF compensation

SnJ

Free Member
Feb 25, 2018
100
61
NuL, Staffordshire
Funster No
52,563
MH
2009 Autotrail Dakota
Have a N150 in a 2009 Autotrail Dakota.
About a month ago it started freezing everything in the fridge when on No.1 (mains powered)
This week it'll chill to about 6 degrees on No 1 but as soon as you put it to No 2 it starts heating up.
If I run it on gas it just gets warm.
I have already installed a new thermistor and it has not changed anything.
There are no fault codes on the display
Have done the trolling of the forum plus googled the living daylights out of t'internet
No joy...
Any ideas?

Am thinking new fridge at this rate :worried:
 

Jaws

LIFE MEMBER
Sep 26, 2008
23,870
74,328
Thetford Norfolk
Funster No
4,189
MH
C class, Chieftain
Exp
since 2006 ( I think ! )
Have a N150 in a 2009 Autotrail Dakota.
About a month ago it started freezing everything in the fridge when on No.1 (mains powered)
This week it'll chill to about 6 degrees on No 1 but as soon as you put it to No 2 it starts heating up.
If I run it on gas it just gets warm.
I have already installed a new thermistor and it has not changed anything.
There are no fault codes on the display
Have done the trolling of the forum plus googled the living daylights out of t'internet
No joy...
Any ideas?

Am thinking new fridge at this rate :worried:
I gave up with Thetford fridges ... Kept on having odd issues that I had to sort out.. followed by two complete failures.. And Thetford are absolutely NO help at all
Fitted a Dometic in our Autotrail in the end. The one issue I had I spoke to a Dometic rep at a show and sorted it out in two minutes
 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top