Motorhome control panel(EC467) and Alde display panel. (1 Viewer)

Affiliate links here may earn MHF compensation
Oct 11, 2016
1,330
2,250
Bognor Regis
Funster No
45,542
MH
Bailey Adamo 69-4
Exp
6 years
Set off home from Dorset this morning. Usually when the engine starts these displays go out but today the Alde panel remained lit and on the control panel the green charge light to hab battery remained on and vehicle battery was showing amber.
Weatherwise it was very wet and stormy. Also yesterday evening one of the internal lights switched itself on and I wonder if this is related. Any thoughts please.
On another note the engine management light was on and diagnostic machine has indicated "clogging particulate filter".
 
OP
OP
Bognor Saint
Oct 11, 2016
1,330
2,250
Bognor Regis
Funster No
45,542
MH
Bailey Adamo 69-4
Exp
6 years
Update.
I had the AA out this morning. Clogging particulate filter. He tried to regenerate the dpf but no success. Luckily a week still on warranty from dealer so it's booked in on Monday for dpf and odd behaviour from control panel.
 
OP
OP
Bognor Saint
Oct 11, 2016
1,330
2,250
Bognor Regis
Funster No
45,542
MH
Bailey Adamo 69-4
Exp
6 years
Update.
The culprit was the dpf differential pressure sensor.

Subscribers  do not see these advertisements

 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top