ebike fault finding

Discussion in 'Bikes and eBikes' started by bjandlin, Mar 16, 2019 at 8:39 AM.

  1. bjandlin

    bjandlin Funster

    Joined:
    Feb 29, 2012
    Messages:
    292
    Location:
    Reading & Surgeres France.
    Ratings:
    +264
    Good morning,
    Is there an ebike expert out there who could help with a problem please ?
    I have a Kalkhoff Activity Groove with a front drive motor.
    Initial power assistance is good & then restart the assistance doesn't return. It will only start again if you virtually come to a halt.
    My initial thought was that the bottom bracket sensor was at fault.
    I booked it into my local bike shop who liased with Kalkhoff who supplied a bottom bracket & circuit board.
    FOC.
    With these changed the problem still exists.
    I have tried to get details of wiring to check & also what the motor sensors do but to no avail.
    The next route looks to be to change the front motor but I am obviously reluctant on cost grounds.
    Any ideas or advice would be so welcomed.
    Thanks.
    Barrie.
     
  2. bjandlin

    bjandlin Funster

    Joined:
    Feb 29, 2012
    Messages:
    292
    Location:
    Reading & Surgeres France.
    Ratings:
    +264
    Sorry should have reread before posting.
    Should read that once you stop peddaling & restart assistance doesn't return..
     
  3. tonyidle

    tonyidle Funster

    Joined:
    Aug 6, 2013
    Messages:
    6,829
    Location:
    Kendal, Cumbria
    Ratings:
    +9,504
    It sounds more like the controller than the motor. If you get normal assistance at first then none after you have stopped pedalling the motor is fine - it's just a motor - and the controller isn't recognising the pedal sensor. Unless the controller is inside the motor - I know of at least one that is but don't know about yours.
     
  4. Tinker2

    Tinker2 Funster

    Joined:
    Feb 28, 2016
    Messages:
    181
    Location:
    Cornwall
    Ratings:
    +541
    Check the sensor is lined up. Good luck with 50 cycles if that's who you got it from, as you will need it.
     
  5. Lenny HB

    Lenny HB Funster Life Member

    Joined:
    Oct 18, 2007
    Messages:
    16,253
    Location:
    On the coast in West Sussex
    Ratings:
    +27,588
    Have you done a search on youtube often a few experts on there.
    Otherwise I think you need to get it to a Kalkhoff dealer with proper diagnostic software. That's what we have to do with our Bosch units.
     
  6. jockaneezer

    jockaneezer Funster

    Joined:
    Dec 12, 2010
    Messages:
    2,722
    Location:
    Cumbria
    Ratings:
    +9,506
    I'm not familiar with that model, but it sounds to me like it may be the crank torque sensor that's playing up.
     
  7. two

    two Funster

    Joined:
    Aug 4, 2011
    Messages:
    3,080
    Location:
    West Midlands
    Ratings:
    +3,219
    I'd go along to any e-bike specialist. Sounds like the torque sensor but I'm sure a competent person would be able to track down the problem very quickly. These things are not new and I find (UK) bike shops very keen and helpful.
     
  8. bjandlin

    bjandlin Funster

    Joined:
    Feb 29, 2012
    Messages:
    292
    Location:
    Reading & Surgeres France.
    Ratings:
    +264
    Thanks all for your comments.
    I've had a look at youtube but not found anything yet.
    I have tried to contact 50 Cycles but they don't seem to return email requests for information.
    The cycle shop I used were very helpful & liased with Derby cycles the manufacturer in Germany.
    They supplied the replacement parts FOC which was good as the bike is well out of warranty.
    I have since emailed them to try get further info but no joy there .
    So I'l lkeep digging.
    Have had no joy with a Bafang search either.
    Thanks again.
    Barrie.
     
  9. two

    two Funster

    Joined:
    Aug 4, 2011
    Messages:
    3,080
    Location:
    West Midlands
    Ratings:
    +3,219
    I wouldn't waste time with 50 Cycles. They may have traded in Kalkhoff but managed to wreck mine.
    Not sure what the Activity Groove is but, if it has a Bafang, I think that's been electrified after purchase. More recent Kalkhoffs had Panasonic or Impulse drives (and, I think Bosch recently).
     
  10. bjandlin

    bjandlin Funster

    Joined:
    Feb 29, 2012
    Messages:
    292
    Location:
    Reading & Surgeres France.
    Ratings:
    +264
    It is original, about 2015 vintage so not an upgrade.
    My first impression was a faulty bottom bracket but since that's been changed I have to look elsewhere. I've looked at multiplug pins for any signs of misalignment but would like a circuit diagram to multi meter test it through.
    As you say 50 cycles were a lost cause & Kalkhoff not much better.
    Ho Hum, onward we go.
    Barrie
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice