Thetford N150 /N175

Discussion in 'Heating and Air-Conditioning' started by Biggles, Nov 8, 2014.

  1. Biggles

    Biggles Funster

    Joined:
    Sep 2, 2009
    Messages:
    151
    Likes Received:
    33
    Location:
    Essex
    Hi All

    My fridge is lighting then going out about 5 seconds later, then doing it all over again time after time.

    I suspect it a dodgy thermocouple however I cant find one, so I am wondering if somehow the ignighter is also a thermocouple. I did ben this into the flame a bit more and after it stayed alight for about 3 minutes before going back to its old routine.

    Any suggestions please?
     
  2. DP_JAY

    DP_JAY Funster Life Member

    Joined:
    Mar 17, 2010
    Messages:
    1,797
    Likes Received:
    1,022
    Location:
    Cark, Cumbria
    It doesn't have a thermo couple as such, the electrode passes a signal back to the board.
    Had the same problem with ours, got a new board & electrode from here.

    http://www.leisurespares.co.uk/contact/

    Very helpful people.
     
  3. tonyidle

    tonyidle Funster

    Joined:
    Aug 6, 2013
    Messages:
    2,866
    Likes Received:
    2,684
    Location:
    Kendal, Cumbria
  4. DP_JAY

    DP_JAY Funster Life Member

    Joined:
    Mar 17, 2010
    Messages:
    1,797
    Likes Received:
    1,022
    Location:
    Cark, Cumbria
    Yes I changed the electrode, It worked OK for a couple of weeks, but ended up changing the board as well. Luckily I'd bought both while I was there.
     
  5. Biggles

    Biggles Funster

    Joined:
    Sep 2, 2009
    Messages:
    151
    Likes Received:
    33
    Location:
    Essex
    Looks like the same has now happened to me :-(
     
  6. DP_JAY

    DP_JAY Funster Life Member

    Joined:
    Mar 17, 2010
    Messages:
    1,797
    Likes Received:
    1,022
    Location:
    Cark, Cumbria
    Leisurespares were the cheapest & very helpful.
     

Share This Page