Swift Sundance 630l probable battery issue

Discussion in 'Swift Motorhomes' started by Asterix, Feb 3, 2010.

  1. Asterix

    Asterix Read Only Funster

    Joined:
    Feb 3, 2010
    Messages:
    11
    Likes Received:
    5
    I have had a 630l for 2 years now.

    Parked it out front of the house in October with no discernible battery problems (i.e. we'd been away and had plenty of power).

    It's been on hookup since with all electrics turned off, except for the odd occasion when I've gone in, turned lights on, then off, come out again.

    Now, 4 months later, the internal lights when used on the leisure battery are very dim.

    Am assuming that means the battery needs replacing unless anyone can suggest otherwise (does the leisure battery only charge if you configure the electrical control panel in a certain way - i.e. select "leisure battery" via the 3 position rocker switch on the extreme left instead of "electrics off" or "vehicle battery")?

    How can I check the battery independantly (i.e. to ensure it's not a faulty relay or some other electrical problem that is not battery related)?

    Thanks for looking.
     
    Last edited: Feb 3, 2010
  2. Rickboy

    Rickboy Read Only Funster

    Joined:
    Dec 2, 2009
    Messages:
    27
    Likes Received:
    0
    Not sure of your m/h set-up but would think you need to set to LEISURE to charge up the internal battery.
    Now its a bit flat don't try to charge it with the onboard charger/12v power supply.Use an intelligent charger on a low amp setting (3amps or so) and leave it connected for a couple of days.
    To prevent it going flat again alternate between the starter battery and the leisure charging positions on the panel.
    Some clever systems sense which battery has the lower voltage and swith accordingly.

    Don't be tempted to use the onboard charger unless it is the intelligent type or your battery will not stand such a good chance of recovery.

    Rick
     
  3. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,442
    Likes Received:
    16,867
    Location:
    YO11 2BD
    probably got the same panel as my kontiki so yes, the panel rocker switch MUST be in the leisure position.
    center position is ALL off....no charge to either battery but i think the power is on to lights, pump etc.
    'cab' position charges engine battery from onboard charger.

    if the leisure battery goes flat, off hookup, you can switch to engine battery on the panel and run the hab lights etc from that but it will obvoiusly flatten the engine battery over time.

    check the leisure battery at the battery itself with a multi meter/volt meter.
    ensure everything is turned off and not on hookup the connect the meter.
    good charge will be around 12.6v...flat will be around 11.5 > 12v..totally dead will be around 10.5v...below that the battery is probably knackered.
     
  4. Rickboy

    Rickboy Read Only Funster

    Joined:
    Dec 2, 2009
    Messages:
    27
    Likes Received:
    0
    Sound advice above ,thanks..
    If the battery has been left in a low state of charge for a month or so it may be sulphated and not accept a good charge.
    A pulse charger "may" revive it . An intelligent charger should start charging a flat battery at a low voltage and build up as it accepts the charge.
    If the battery has frozen it may be damaged so don't stand too close or put it anywhere that will be damaged if it bursts.
    Connect first then stand back to switch on and switch charger off before inspecting.

    Rick
     
  5. mikeange

    mikeange Read Only Funster

    Joined:
    Jun 18, 2008
    Messages:
    26
    Likes Received:
    0
    Location:
    wimborne near new forest

    Hi
    I have a 2008 swift bolero 680fb...my battery was losing charge a lot when left standing....and would not charge with the on board charger.(but would charge with an indepandant charger).
    I took it back to "marquis" dealer,who checked it out.Evidently there was a batch of bad chargers installed into some swift models....so they replaced the charger with a new model under the swift 3 year guarantee.Works fine now...recharges as required.I dont know whether yours is still under warantee...if it is ,get it checked by your dealer.
    regards
    mike
     
Loading...

Share This Page