Renault 2.5 -120 - Limp mode

Discussion in 'Tech/Mech General' started by jtp890, Jun 29, 2016.

  1. jtp890

    jtp890 Funster

    Joined:
    May 16, 2014
    Messages:
    258
    Likes Received:
    193
    Location:
    wakefield
    Thought I,d cured problem. Disconnecting EGR allowed full power, fitted new EGR as thought problem was electrical in unit, feeding wrong information. Still no change, in limp mode, drives well when EGR disconnected. Do I just keep disconnected, many sites suggest this. No warning lights on dash.
    Any help appreciated.
    Jim
     
  2. MH 55 FUN

    MH 55 FUN Funster

    Joined:
    Feb 18, 2016
    Messages:
    1,990
    Likes Received:
    2,935
    Location:
    South West Wales.
    Do you have an OBDII reader ?

    Are there any OBD codes when in limp mode ?
     
  3. jtp890

    jtp890 Funster

    Joined:
    May 16, 2014
    Messages:
    258
    Likes Received:
    193
    Location:
    wakefield
    No clear of codes
     
  4. MH 55 FUN

    MH 55 FUN Funster

    Joined:
    Feb 18, 2016
    Messages:
    1,990
    Likes Received:
    2,935
    Location:
    South West Wales.
    How are you disconnecting the EGRV ? - Electrically ?
     
  5. jtp890

    jtp890 Funster

    Joined:
    May 16, 2014
    Messages:
    258
    Likes Received:
    193
    Location:
    wakefield
    Yes removing electrical connector block at EGR
     
  6. MH 55 FUN

    MH 55 FUN Funster

    Joined:
    Feb 18, 2016
    Messages:
    1,990
    Likes Received:
    2,935
    Location:
    South West Wales.
    Without any fault codes diagnosis isn't easy, I'd be tempted to leave it electrically disconnected, which as you have full power available means the EGRV is permanently closed, or mechanically blank it off, which will do the same thing.
     
  7. jtp890

    jtp890 Funster

    Joined:
    May 16, 2014
    Messages:
    258
    Likes Received:
    193
    Location:
    wakefield
    Thanks for help
     
    • Like Like x 1
Loading...

Share This Page