Peugeot Elddis Autoquest 120 Instrument Panel

Discussion in 'Tech/Mech General' started by aande, Apr 7, 2010.

  1. aande

    aande Read Only Funster

    Joined:
    Oct 28, 2008
    Messages:
    11
    Likes Received:
    0
    Hi All, this is the 1st time I've posted a thread since owning my Elddis Autoquest 120, 08 Jul plate from new, now with 10,500 miles on the clock. Planning this years trip and have elected to go to Italy in May. Service not due until Jul and a bit troubled with the 5 x circles that used to show up on first start up - they have reduced to 3 yet when I check the oil level the dip stick shows full. Elected to put the motorhome into the local Peugeot garage for a 1st aid check and the receptionist suggested that i have a diagnostic check (£65). Started up the motorhome (0915) this morning to take it to the garage for the checks and shocked to find that the instrument panel was dead - no indicators, no tripometer, no petrol guage, no speedometer etc dead all dead yet the engine was running. I gingerly ran to the garage (not far from home thank goodness) advised of the new problem and left them to it. Phone call at 1600 to say that diagnostics revealed problem with wire loom behind the dashboard which had apparantly been rubbing against the steering colum and another minor electrical fault that had been fixed with a download to the ECU. Holding motorhome overnight to complete the safety checks tomorrow morning.

    I am still shaking at the thought of being somewhere remote in Italy with a minimum understanding of the language and a dead motorhome. Has anyone else had this problem with an Elddis? Can any of you with technical experience assure me that the motorhome is ok after this work has been done or should I be checking for anything else. I am an administrator not a technician!
     
  2. wizza

    wizza Funster

    Joined:
    Aug 3, 2008
    Messages:
    109
    Likes Received:
    45
    Location:
    Essex
    If its less than 3 years old surly it will still be under warranty ?
     
  3. aande

    aande Read Only Funster

    Joined:
    Oct 28, 2008
    Messages:
    11
    Likes Received:
    0
    yes it is still under warranty - I'm not due back to the garage until tomorrow so I'll find out if there are any extra costs then. If I'd been on the road all I would have thought about was a blown fuse and I would find it fairly difficult even to check them properly! I just thank my lucky stars that I decided to put the camper in for a check instead of waiting for my return in Jul for the annual inspection.
     
  4. wizza

    wizza Funster

    Joined:
    Aug 3, 2008
    Messages:
    109
    Likes Received:
    45
    Location:
    Essex
    Is it on a Peugeot chassis ?
     
  5. wizza

    wizza Funster

    Joined:
    Aug 3, 2008
    Messages:
    109
    Likes Received:
    45
    Location:
    Essex
    Sorry Just read the post again see you put peugeot, As a Peugeot tech myself working at a main dealer in essex there should be no cost to you at all they should not even charge you diag charges if they try to charge you ask them for peugeots customer service number and complain
     
  6. lorger

    lorger Funster

    Joined:
    Jul 11, 2008
    Messages:
    6,190
    Likes Received:
    7,560
    Location:
    Dumfries
    Hi aande
    We have a 130 elldis and although we didnt have same problem as you we did have an electrical problem while in France called our break down service who sent someone fixed it but came back again couple of days later we just stopped at a peugeot garage they spoke no english but with some pointing and hand signals i explained the problem they took a car out of bay put mine in and two guys worked on it for 1/2 hour no charge it was only 18months old but they took no details so i assume they didnt put it through as warranty doesnt help you but trying to reasure you if anything happens abroad.

    Wizza you say you work for peugeot so hope you dont mind if i ask a question ours is an 06 with 11k on clock had first service at main dealer but now get it done at a local hgv garage who done the mot but it still has the wee spanner to say service is due do you know how i can clear this not a major problem as i have book stamped to prove service record just a bit annoying

    Cheers Gerry
     
  7. Steve928

    Steve928 Read Only Funster

    Joined:
    Aug 28, 2009
    Messages:
    19
    Likes Received:
    0
    The dipstick on the 2.2 Puma seems to trap oil above itself, and always reads full when first drawn out.
    You need to remove the dipstick and clean it, and wait a few minutes for the oil in the tube to drain too. Then take a fresh measurement and this should be accurate - and in line with the electronic display on the dash.
     
  8. aande

    aande Read Only Funster

    Joined:
    Oct 28, 2008
    Messages:
    11
    Likes Received:
    0
    Peugeot Elldis Autoquest 120

    Hi all. Just returned from the garage. Pleased to advise that they did not charge me for the diagnostic check. They completed the 1st aid check this morning and state all is in good shape. I noticed that the oil circles still only show three white rings instead of the original 5 black rings and my handbook dosnt mention these rings at all!
     
Loading...

Share This Page