No 12v Power to fridge when engine running!

Discussion in 'Motorhome Chat' started by wardy, Jul 19, 2013.

  1. wardy

    wardy Read Only Funster

    Joined:
    Feb 1, 2010
    Messages:
    4
    Likes Received:
    0
    Hope someone can assist. I have a Compass Navigator on a VW p plate and have no 12 v power to fridge when engine running. Have replaced 12v switch as there was evidence of heat damage from power in middle brown cable. Am I missing a fuse? I would be grateful for any help.
     
  2. GJH

    GJH Funster Life Member

    Joined:
    Aug 20, 2007
    Messages:
    27,227
    Likes Received:
    34,398
    Location:
    Acklam, Teesside, originally Glossop
    When I was researching during renovations to our son's camper van I found that there is normally a relay and a 15 amp fuse in the circuit between the starter battery and fridge.
     
  3. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,441
    Likes Received:
    16,867
    Location:
    YO11 2BD
    there will be a relay under the bonnet , close to the battery, which latchs when the engine is started providing power to the fridge.

    If this fails then no 12v supplied.

    Go back to the switch and connect a multi/volt meter to it and an earth point to check for 12v at the switch with the engine running.

    If you have 12v there then there's a problem with the fridge...If not it could be the relay is stuck open or its fuse has blown...that should also be near the relay.
     
Loading...

Share This Page