Electrics on Fiat Bessacar

Discussion in 'Motorhome Chat' started by palio, Oct 14, 2010.

  1. palio

    palio Read Only Funster

    Joined:
    Sep 4, 2010
    Messages:
    1
    Likes Received:
    0
    Hi, Can anyone shed any light on how to restore the electrics on my 2004 fiat Bessacar 425. Plugged our 240v Hoover into one of our sockets in the van whilst hooked up to 240volt supply, hoover turned over once then put all electrics in habitation part of the van out. Didnt trip the switches in the consumer unit and all fuses look O.K. ?
     
  2. Geo

    Geo Trader - Funster

    Joined:
    Jul 29, 2007
    Messages:
    9,508
    Likes Received:
    5,562
    Location:
    Mansfield,Notts
    It can only be a re set button youve missed, if as you say every thing else is ok
     
  3. Dodgey

    Dodgey Funster

    Joined:
    Oct 15, 2007
    Messages:
    1,603
    Likes Received:
    227
    Location:
    Gone RVing
    Daft possibly, but have you checked the fuse in the hoover plug?
     
  4. pablomc

    pablomc Funster Life Member

    Joined:
    Apr 20, 2010
    Messages:
    860
    Likes Received:
    235
    Location:
    Co. Durham
    Could be the hook up connection, e.g trip on normal hook up if you are on site. Plug fuse if you are using a 3 pin converter to the house, ring main trip/ fuse or RCD in the house consumer unit.
     
  5. scotjimland

    scotjimland Funster Life Member

    Joined:
    Jul 25, 2007
    Messages:
    28,934
    Likes Received:
    25,574
    Location:
    .
    Check the trips again, some types don't go to the off position and can be easily missed.

    switch off each trip in turn to reset it, then switch on , in both house and van consumer units.
     
Loading...

Share This Page