Comnitronic

Discussion in 'Motorhome Chat' started by colin&lesley, Apr 15, 2010.

  1. colin&lesley

    colin&lesley Read Only Funster

    Joined:
    Oct 2, 2009
    Messages:
    18
    Likes Received:
    0
    Location:
    WidmerEnd Nr High Wycombe
    Hi
    I have recently bought a Autocruise Stardream that has a Combitronic water heater. Its been working fine up to today. The panel that operates the system will not turn on, does anyone know about this system who can help. Its always turnes on previously and I wonder if it has a fail safe cut out if it detects no water in the tank or something???

    Regards

    Colin
     
  2. scotjimland

    scotjimland Funster Life Member

    Joined:
    Jul 25, 2007
    Messages:
    28,934
    Likes Received:
    25,574
    Location:
    .
  3. ingram

    ingram Read Only Funster

    Joined:
    Aug 9, 2008
    Messages:
    87
    Likes Received:
    1
    I have a Combi Compact in my Starblazer. I don't offhand know what might be wrong with yours although I do have some experience of mending my Eberspacher. You should never run the hot water system on mains without water in the tank but i doubt doing so would prevent the panel turning on. Do you have a standard or 'De-luxe' control panel?

    Sorry I can't help more and I am just off in the Renault in about five minutes. I'll see how you have got on next week.

    ...and yes what Jim says sounds a good possibility.

    Harvey
     
  4. ingram

    ingram Read Only Funster

    Joined:
    Aug 9, 2008
    Messages:
    87
    Likes Received:
    1
    I'm back ......... but there's no update ....... in case you haven't fixed it, there is probably a separate power supply and fuse to the Combitronic from the leisure battery: there is in my Starblazer. The fuse is adjacent to the leisure battery; there are two, one for the Combi and one for 'everything else'.
    hth

    Harvey
     

Share This Page