Well that didnt last long ... A class Daily Drive.

PhilG

Free Member
Mar 8, 2016
1,583
4,089
leicester
Funster No
41,924
MH
euramobil 810
Exp
since birth
So 4 days in , and this morning she dont wanna go.. spins like a good un but no litey..

Thinking it may have been glowplugs, i did what any proper bloke would do... keep your foot in and turn it till it goes. It didnt.

So.. tough choice.. do i take the van with no MOT or tax, wake the boy , or ask the wife to drive 20 miles out of her way.

So after a very quiet 10 mile drive, and all day at work wondering how much £££ i am going to have to drop to get it fixed, i blag a lift home and crack on.

I am no rookie, but i had to google where the filter housing was, and even then i couldnt see it with the lights i had, so 10 minutes of buggering about with lights and cables , and i am good to go , find the filter housing on the bulkhead on the near side , behind the air filter housing .

Finding it and getting at it are not the same, and after a bit of persuasion, the filter came out, possibly to never to go back in again.

So now i can get to it, i check for leaks , but no smell of sign of fuel, nothing on the floor, or anywhere under the vehicle.

Luckily the filter is the old type that screws on and not the two peice plastic jobby, and when i get my fingers to it to see if its tight, and not only is it not tight , it moves freely. Now that is a result.

After digging out my rubber palmed gloves (no laughing at the back) i get enough on the filter to snug it back into place, and after priming the system (3 times on with the ignition for 15 secs) she fired up first go.. like better than it did before.

So .. why did it happen. Well it was serviced maybe 12,000 miles ago, before i got her, always been a good starter , unless she stands for a few weeks, and then it spins a bit longer than you would like, but it always goes, and runs fine.

When i fired her up at New Year to get her back on the front of the house, it took a bit, and then was almost as bad the next day.

In reality, it has started 6 times since we came back from Belgium .. so could have been worse

So if you have a 2.8 JTD and it starts to get less willing to go , get it checked out before it does you over.
 
Feb 22, 2011
5,854
8,380
Newcastle under Lyme
Funster No
15,397
MH
Hymer B544 A Class
Exp
Since 2015
So the fuel filter was loose and preventing it starting ? Tightening it up fixed the problem ?
Must have been sucking in air maybe.
Probably due for a replacement too as you don`t know if it was replaced last service do you
 
OP
PhilG

PhilG

Free Member
Mar 8, 2016
1,583
4,089
leicester
Funster No
41,924
MH
euramobil 810
Exp
since birth
So the fuel filter was loose and preventing it starting ? Tightening it up fixed the problem ?
Must have been sucking in air maybe.
Probably due for a replacement too as you don`t know if it was replaced last service do you
Yes, it was , and it did.

I will change it as soon as i dont need to use it every day.

Subscribers  do not see these advertisements

 
Aug 26, 2008
3,039
12,494
B&NES
Funster No
3,823
MH
Van Conversion
Exp
since 2007
"serviced maybe" sounds plausible. Caveat emptor as the Romans would say.
 
OP
PhilG

PhilG

Free Member
Mar 8, 2016
1,583
4,089
leicester
Funster No
41,924
MH
euramobil 810
Exp
since birth
"serviced maybe" sounds plausible. Caveat emptor as the Romans would say.

The 'maybe' was for the mileage... it was at 27000 miles when I got it 2 years ago, from a dealer and it was fully serviced by the previous owner with receipts .

I don't recall the mileage but I negotiated a good chunk of change off the price for taking it with a hab check only ,and 3 months warranty ,and the balance of MOT rather than a fresh one. it had brakes and tyres done and a full service .

The only 'issue' was that we did a deal based on it having had a cambelt change, and there was no evidence paper, or otherwise of it being done. He agreed to pay what he would pay to get it done , and I had my guy local do it.

Taking the air filter off last night, it was that clean it wasn't worth firing the compressor up to blow it out.

Happy to say it went straight away , and I notice that the glow plug light which had stayed on yesterday, went out as soon as the fuel pump primed, so it seems like its a pressure warning too.
 
OP
PhilG

PhilG

Free Member
Mar 8, 2016
1,583
4,089
leicester
Funster No
41,924
MH
euramobil 810
Exp
since birth
Just surprised it didn't leak everywhere.
Glad you got it sorted.
Me too, usually you smell the leak before you see it and it stops.. no sign at all , which is what concerned me.
 
Top