Webasco Dual Top RHA 101 / 102 - Controller Screen Issue

Oct 21, 2020
4
2
Funster No
77,102
MH
Murvi Morello
Exp
Since 1995
Hi funsters,
I have recently (just before lockdown) had a problem with our 2011 Murvi's heater controller and was wondering if anyone has had a similar problem?
After running the heater for a few hours the electronic controller screen 'plays up'.
The heater itself continues to function, it responds to key entries as one would expect.
I have taken the screen out and looked inside, there are no loose cables/ribbons.
Tapping the unit makes no difference. Has anyone had one of these repaired or know company that could?
The photos are examples of it playing up.
webasco 1.jpg
webasto 4.jpg
 

DBK

LIFE MEMBER
Jan 9, 2013
15,786
34,937
Plympton, Devon
Funster No
24,219
MH
PVC, Murvi Morocco
Exp
2013
Looks like a faulty LCD screen or the chip controlling it to me. :( Webasto have a network of agents around the country so you could try contacting one near you. Of course, normal support services may not be running smoothly at the moment.

But it might be worth pulling all the fuses out, there should be three of them. From memory (always risky) replace them from the smallest first which might be 5A and the other two are 10A. This will reboot it.
 
OP
B
Oct 21, 2020
4
2
Funster No
77,102
MH
Murvi Morello
Exp
Since 1995
Thank you DBK, I have emailed a couple of agents. I spoke to Rex and he suggested re-making the connections, so that rebooted the controller. Didn't make the problem go away though. it's a strange one as I would expect the LCD to fail but it comes back after a while. I'm guessing it's a component breaking down that gets rattled after a few hours use. Heater works fine but changing the power source is tricky without a display! Thanks for the advice.

Subscribers  do not see these advertisements

 
Passionate about energy
West Country Motorhomes
Rhino Installs
Friendly professional service from qualified technicians
Top