Water heater pump keeps running

Discussion in 'Tech/Mech General' started by Gary and Sarah, Apr 26, 2016.

  1. Gary and Sarah

    Gary and Sarah

    Joined:
    Apr 26, 2016
    Messages:
    1
    Location:
    Cornwall
    Ratings:
    +0
    We have just come back from our first trip away in our Cheyenne 632 (2004) no problems except that the heating pump wont stop. We have disconnected it by pulling a wire off of it in case we are damaging it. Does anyone know what we've done wrong? Many thanks.
     
  2. tonka

    tonka Funster Life Member

    Joined:
    Jul 2, 2008
    Messages:
    6,181
    Location:
    Cannock, Staffs or Benidorm, spain
    Ratings:
    +11,378
    Most likely a leak somewhere.... Does not have to be a big one and could be just a loose connection.. Also if you have a screw on filter make sure that is OK..

    Welcome to Fun..
     
  3. chaser

    chaser Funster

    Joined:
    Feb 16, 2013
    Messages:
    9,178
    Location:
    uttoxeter
    Ratings:
    +14,663
    What do you meen by heating pump? Do you meen the water pump , which is what tonka has replied, or the boiler , two different things.(y):)
     
  4. tonka

    tonka Funster Life Member

    Joined:
    Jul 2, 2008
    Messages:
    6,181
    Location:
    Cannock, Staffs or Benidorm, spain
    Ratings:
    +11,378
    Good point..I am assuming a water pump.. As that's most likely and the only ones I know about.. :)
     
    • Like it Like it x 1
  5. scotjimland

    scotjimland Funster Life Member

    Joined:
    Jul 25, 2007
    Messages:
    29,094
    Location:
    .
    Ratings:
    +28,349
    Is it the Alde heating circulation pump ?
     
  6. Targetpaster

    Targetpaster Funster

    Joined:
    Oct 25, 2015
    Messages:
    181
    Location:
    Devizes
    Ratings:
    +100
    I have had this problem and it's most likely a collapsed diaphragm in the dump valve which causes a small drip leak which drops the pressure enough to kick start the pump
     
Loading...

Share This Page