Thetford Fridge Freezer N3145 Error Code 10. (1 Viewer)

Affiliate links here may earn MHF compensation
Nov 22, 2018
1,845
16,157
South East but not London
Funster No
57,328
MH
Rimor Europeo 87
Exp
Five years plus three tugging
Totally annoying. Started up fridge ready for the season and got Error code 10 (no 230v)

Some factors
We have a EHU socket at our house, and we connect the bus to it, a few days before we travel
The Nord control panel shows that the mains cable is fitted.
I have plugged in a kettle into a three pin plug as a test, and it worked fine.
The fridge is on and cold, using gas.
I have switched the engine on and the fridge works fine on 12v
We had a full 12v and 230v electrics survey done in January.

The attached troubleshooting guide for the N3000 series, says that it is a Power board issue. Could it be anything else?

If it is power board, is it a self or dealer fix?
 

Attachments

  • Troubleshooting N3000-EN.pdf
    258.4 KB · Views: 144
Aug 22, 2007
2,581
33,961
essex
Funster No
145
MH
2017 sunlight t69s euro6
Exp
since 1999
My fridge does the same thing sometimes I switch the fridge off dis con the elec lead and leave it for a few mins and try again , the main power board is behind the lower vent it is a bit tricky to change so take photos first a new board is around £160 on e bay
 
Feb 19, 2020
1,474
1,654
North Ayrshire
Funster No
68,864
MH
Adria Matrix 670SC
Exp
Newbie
Are you able to confirm that 230v is getting to the input connection on the rear of the fridge ?
As well as that have you checked the consumer unit for a trip.

Subscribers  do not see these advertisements

 
OP
OP
DDJC
Nov 22, 2018
1,845
16,157
South East but not London
Funster No
57,328
MH
Rimor Europeo 87
Exp
Five years plus three tugging
Dear all.

Thanks all so much for your advice, but please stand down. I have fixed it; not that it required much fixing.

I am however exceptionally peeved by it.

A month ago, I put the van into a workshop (not going to say which) for a 12v and 230v electrical healthcheck. A few weeks later (Weds last week) I tested and checked everything to ensure that we were fit to travel. It was at this point that I found that the fridge only worked on 12v and gas. Nevertheless, we decided to head off for the Easter weekend. On Sunday morning, I decided to take out the lower ventilation grill and see whether the power unit was a workshop or a DIY.

There in front of me was the mains connection plug and socket ... not connected. Pushed them together, the gas flicked off and looking inside, it had seamlessly converted to 230v EHU. Relieved but bloody annoyed.

Won't be using that workshop again.
 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top