Thetford fridge 12volt (1 Viewer)

The Tafia

Free Member
Jul 21, 2014
50
38
Funster No
32,497
MH
Coach-built Hi Top
Exp
4 days
For two days my Thetford fridge has been on 240 volt. I was leabing home today and checked the fridge was on12volt but it was not. All the lights were flashing. When this happened in the past I removed yje pannel on the outside of the MH dissconnect the two molex plugs re plig them in and the fridge was ok bit today I could not get ot to work.
Any ideas greatly appreciated.
 
Jan 8, 2013
8,496
11,538
Dronfield - Derbyshire
Funster No
24,202
MH
Burstner Lyseo 690G
Exp
Happy FLT since 2011
Mine stopped working on 12v last year and I've still not bothered to fix it. I just leave it on gas. I'm told that there's a fuse on the control panel but I've yet to look. Let me know how what you find.
 
OP
OP
The Tafia

The Tafia

Free Member
Jul 21, 2014
50
38
Funster No
32,497
MH
Coach-built Hi Top
Exp
4 days
Do leave it on gas when driving? I thought that was a no no.
 
Jul 14, 2022
649
1,300
Funster No
89,902
MH
Autosleeper Dorest E
Exp
Jul 22
Do leave it on gas when driving? I thought that was a no no.
I can vouch for reasons not to do that (view my post about this from Friday...unsure how to send links, sorry) so yes, defo no no for us
 
Dec 17, 2016
970
990
Malvern
Funster No
46,488
MH
Hymer B525 2006 A cl
Exp
2012
Do leave it on gas when driving? I thought that was a no no.
If you have a safety / crash cut off on the regulator it's okay to run on gas. With an AES fridge it will turn off automatically when you turn off the engine so no risk of fire when you are at a petrol station. It only tuns back on 15mins after restarting the engine.

Subscribers  do not see these advertisements

 
Feb 19, 2020
1,448
1,593
North Ayrshire
Funster No
68,864
MH
Adria Matrix 670SC
Exp
Newbie
For two days my Thetford fridge has been on 240 volt. I was leabing home today and checked the fridge was on12volt but it was not. All the lights were flashing. When this happened in the past I removed yje pannel on the outside of the MH dissconnect the two molex plugs re plig them in and the fridge was ok bit today I could not get ot to work.
Any ideas greatly appreciated.
See post 16 https://www.motorhomefun.co.uk/forum/threads/dometic-3-way-fridge-issue.275970/#post-5406512
 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top