Thetford C200S cassette toilet not flushing (1 Viewer)

Affiliate links here may earn MHF compensation
Mar 20, 2021
24
33
Funster No
79,901
MH
A class
I’m hoping someone can help with this. According to the base of the waste cassette, my toilet is a Thetford C200S. It has a wall mounted flush and takes the water directly from the fresh water tank. However, the flush isn’t working and I don’t know why. I can’t see that there is much that can go wrong with it but I don’t know what to do. Help!
 

Kirsten

LIFE MEMBER
May 5, 2015
859
3,500
Stratford on Avon
Funster No
36,214
MH
Hymer B544
Exp
Since 2010
No tech help sorry but if you are away and in van unflushed ❤️Obs just use water from a cup / bowl for now . Some vans have wires in the cassette housing - check / wiggle these . Are you sure your water tank is full
 
Upvote 0
OP
OP
H
Mar 20, 2021
24
33
Funster No
79,901
MH
A class
Thanks everyone. Yes, the water tank is full and the pump is running. I don’t know if I can remove the wall mounted flush and have a look at it? Although, I wont know what exactly I’m looking at! Lol!
 
Upvote 0
OP
OP
H
Mar 20, 2021
24
33
Funster No
79,901
MH
A class
No tech help sorry but if you are away and in van unflushed ❤️Obs just use water from a cup / bowl for now . Some vans have wires in the cassette housing - check / wiggle these . Are you sure your water tank is full
That’s what I’m doing atm.

Subscribers  do not see these advertisements

 
Upvote 0
Jul 4, 2018
1,312
1,694
Bristol
Funster No
54,738
MH
Weinsberg
Exp
A few years.
This is a pump operated one? If so does the pump run?
Inside the cassette door you should see a water pipe with a fuse very close to it, is the fuse good?
If yes yes yes so far then it is likely to be a valve high up the outside of of the bowl, close to where the flush water comes out on the inside.
To get to this you need to remove the bowl to get to the thing.
Been there got the T-shirt!
 
Upvote 0
Dec 24, 2014
9,533
49,389
Hurstpierpoint. Mid Sussex.
Funster No
34,553
MH
Compass Navigator
Exp
Ever since lighting was by Calor gas.
Thanks everyone. Yes, the water tank is full and the pump is running.
Since the pump is running and you're not getting water puddling from a disconnected deliver pipe it may be that the impellor on the pump has come loose on its shaft. That happened to my son's which has the pump in the 'cistern'.
If that's the case there's not much you can do about it but replace the pump. It was a simple enough job on my son's.
 
Upvote 0
Apr 3, 2018
3,902
11,027
Funster No
53,151
MH
PVC
Exp
1995-2004 & 2017》
Pump running OK.....water in tank OK.
Water come out of any tap when opened OK.....
If so then I would also suspect the solenoid valve in toilet.👍
 
Upvote 0

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top