Not very flush

Discussion in 'Motorhome Chat' started by plattypus, Jan 11, 2011.

  1. plattypus

    plattypus

    Joined:
    Nov 9, 2010
    Messages:
    12
    Location:
    Ulverston. Cumbria
    Ratings:
    +2
    Hi all
    Can't flush my Thetford loo in my Autosleeper Symbol. Got water in tank. was ok before
    big freeze. Thought i'd drained it all, But would it have made any difference anyway? anyone got any ideas please:Blush:

    plattypus
     
  2. lunarman

    lunarman Funster Life Member

    Joined:
    Sep 23, 2008
    Messages:
    1,568
    Location:
    South Glos
    Ratings:
    +1,087
    I to forgot to drain the flush tank and tried to operate the flush while still frozen. This blew the fuse which is located with the holding tank. Check that you have not done the same.

    Lunarman
     
  3. plattypus

    plattypus

    Joined:
    Nov 9, 2010
    Messages:
    12
    Location:
    Ulverston. Cumbria
    Ratings:
    +2
    no flush

    Thanks Lunarman

    sounds as though it could be my problem, If i can locate pump I'll check:thumb:

    plattypus
     
  4. imprint

    imprint

    Joined:
    Jul 14, 2009
    Messages:
    1,090
    Ratings:
    +11
    Not exactly flushed with success, then.

    (Well someone had to say it - an open door is an invitation....)
     
  5. Bailey58

    Bailey58 Funster Life Member

    Joined:
    Jun 23, 2010
    Messages:
    6,958
    Location:
    Norfolk and Toftir.
    Ratings:
    +14,537
    Another one down the pan! :Blush:
     
  6. Heyupluv

    Heyupluv

    Joined:
    Oct 7, 2008
    Messages:
    3,860
    Location:
    France,
    Ratings:
    +1,584
    Yes but will he come up smelling of "FUSES" :ROFLMAO::ROFLMAO:

    Mel
     
  7. plattypus

    plattypus

    Joined:
    Nov 9, 2010
    Messages:
    12
    Location:
    Ulverston. Cumbria
    Ratings:
    +2
    who's a clever lad ? found pump fuse and, yes blown!! Thanks again for your invaluable assistance Lunarman. Plattypus:thumb:
     
  8. Reallyretired

    Reallyretired Funster

    Joined:
    Apr 27, 2008
    Messages:
    6,242
    Location:
    Eastbourne East Sussex
    Ratings:
    +4,188
    Completely opposite effect on the way to Shepton. Arrived with loo full of water and slopping out on the floor :whatthe:. Appeared to be flushing itself. As the situation rectified itself after a few flushes I can only assume there was some grot stuck in the valve stopping it from closing properly.
     
Loading...

Share This Page