Nordellectronica NE 102C no display unless connected to mains. (1 Viewer)

rickjohnston

Free Member
Apr 14, 2019
5
0
Funster No
59,895
MH
CI Cipro Garage
Exp
Since 2018 (newbie"
Not sure how it happened, but getting the motorhome out of winter storage, the NE 102C display panel was blank. I assumed the house bank was depleted. It started fine, drove it home and plugged into the mains. The display showed low voltage, and the switches worked. Next day batteries are at 13.5 and when removed from mains the display goes blank and the switches are inop. No 12v useable.
Any Ideas?
Many thanks in advance.
 

Riverbankannie

LIFE MEMBER
Mar 11, 2016
10,670
62,298
Bristol
Funster No
41,967
MH
IH 630 RL PVC
Exp
12
:hiya:

I assume from the way you have written the above that the display showed 13.5 v whilst still hooked up to EHU. Once disconnected your hab battery could be still dead if it’s been left over the winter.
Others will be along soon to tell you how to check it.
 
OP
OP
R

rickjohnston

Free Member
Apr 14, 2019
5
0
Funster No
59,895
MH
CI Cipro Garage
Exp
Since 2018 (newbie"
I've put a meter on the hab batteries, they show 13.3v but there is no display and no 12v for interior lights and pumps. I've checked all the fuses I can find. no "opens".
 

TerryL

LIFE MEMBER
Mar 5, 2010
6,208
8,220
North East
Funster No
10,511
MH
Low Profile
Exp
2009
Try a simple reset before you do anything else.

Carefully prize off the bezel surrounding the screen then unscrew the unit. Carefully remove and take off the electrical connecting plug on the back and leave for a couple of minutes.
Now put it all back - this usually solves problems with this unit.
If this doesn't work unfortunately you can't buy a replacement but there is a firm that can repair them, can't remember the name but someone will come up with it shortly.
 
OP
OP
R

rickjohnston

Free Member
Apr 14, 2019
5
0
Funster No
59,895
MH
CI Cipro Garage
Exp
Since 2018 (newbie"
Great, thanks, I'll give it a try.

Subscribers  do not see these advertisements

 
OP
OP
R

rickjohnston

Free Member
Apr 14, 2019
5
0
Funster No
59,895
MH
CI Cipro Garage
Exp
Since 2018 (newbie"
Well,, no joy.. but I did take a few pictures for reference.
 
Jul 5, 2013
11,759
13,768
Tunbridge Wells, Tunbridge Wells, UK
Funster No
26,797
MH
A class
Exp
Since 2013
The 13.5V is probably the charge voltage. Unplug the mains, and then check your battery voltage using a multi meter on the terminals. If you have left the battery uncharged over the winter it could well be goosed.

Subscribers  do not see these advertisements

 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top