my globespan summit 640 pump not working (1 Viewer)

Affiliate links here may earn MHF compensation

Dodgydave1

Free Member
Apr 21, 2023
2
0
Funster No
95,403
MH
globecar
Can anyone help plenty of water. Fuses ok pump not making a noise any help please
 
Dec 24, 2014
9,540
49,426
Hurstpierpoint. Mid Sussex.
Funster No
34,553
MH
Compass Navigator
Exp
Ever since lighting was by Calor gas.
Is it your first try this year?
Do you have a test meter? (Every motorhomer ought to; a ten quid one will suffice for basic checks).
If so, check for voltage at the pump - when turned 'ON' obviously.

Fuses can 'look' O.K. but be blown. Best way is to check them with a meter.

There was a thread yesterday that may give you some clues/guidance..............

 
Upvote 0
Aug 10, 2012
858
943
cambridge
Funster No
22,344
MH
Globecar
Exp
since2001
Chances are you have left the tap slightly lifted but not enough to let water out, the switch in the tap makes the pump run , no water can get out and the pump fails due to running but not pumping
new pumps are cheap and easy to get , buy two and carry a spare
 
Upvote 0

hja

May 8, 2020
1,047
3,385
Lincolnshire
Funster No
70,433
MH
Globecar Summit Prim
Exp
Since 2019
Our Summit Prime pump stopped working last year, despite giving it a good shake. Took it in to be changed, under warranty, they changed it, but said that actually it had stuck. Not sure what had stuck. We are not good at this sort of thing. So maybe take it out and see what you can do. This was at the height of parts shortages, they ended up putting a more powerful pump in, which is actually much better, flushes the loo properly now.
 
Upvote 0

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Latest journal entries

Funsters who are viewing this thread

Back
Top