Mains unit cooling fan woes

Jun 22, 2014
472
605
Rotherham
Funster No
32,070
MH
Coach built
Exp
5 Years
The cooling fan on our mains 'Box of tricks ' which manages 240 volts , media unit etc seems to run a lot more than I would have expected, ie it switches on after only having been connected to mains for a short time then cycles on and of until I disconnect the site supply. Is this normal ?
It's on my autotrail apache by the way.
Also the control panel above the entrance door shows a green light when I first switch on the 12 volt supply but then goes straight to red. I suspect these two things are related
 
Aug 6, 2013
10,133
12,055
Kendal, Cumbria
Funster No
27,352
MH
A Class
Exp
since 1999
If the red light means the 12v system is over-loaded try removing fuses or switching off breakers for the 12v systems. If the red light goes to green after doing this replace each fuse or switch on breakers one-by-one until you get the red light. The circuit that makes the light go red is the problem.

If the red light stays on after you have disconnected all the 12v feeds check your leisure battery or batteries' voltage.
 
Apr 9, 2013
664
364
Ayr
Funster No
25,458
MH
A class
Exp
Newbie
I suspect your battery voltage is dropping too quickly, probably just knackered, which is making the mains unit work overtime as it tries to charge it back up.

Do you have a multimeter?

Tim

Subscribers  do not see these advertisements

 

tonka

LIFE MEMBER
Jul 2, 2008
8,984
15,467
Cannock, Staffs
Funster No
3,141
MH
A class Burstner 800
Exp
Since 2000
As above.. Contact Sargent, very helpful and they also off a fixed price repair if needed..
My friend had an issue with his EC325 unit and had to send it back. Repair / replacement was back in less than 5 days..
 
Top