Intermittent Shurflo pump problem (1 Viewer)

cazd

Free Member
May 4, 2008
21
0
Shrewsbury
Funster No
2,509
MH
C Class
Exp
New - since August 2008
Our motorhome is 3 years old and has a 20psi Shurflo pump. A lot of the time it works fine, but then for no apparent reason it stops. We have found that we can cure it by tapping what we think is the pressure switch on the top/end (two red wires go into it). This involves removing the contents at the bottom of the wardrobe and removing the base of the wardrobe each time and isn't a longterm solution :Sad: It's especially annoying when it happens when one of us is showering!!

Does anyone know what the cure to this is? If it means getting a spare part then does anyone know of a dealer that supplies Shurflo spares in Central/Southern Portugal??

Many thanks in advance.

Carol
 

scotjimland

LIFE MEMBER
Jul 25, 2007
2,517
10,999
Funster No
15
MH
A Woosh bang
Hi Carol

on the end of the pump, on the switch, there is a pressure adjusting screw, try screwing it in about 1/2 - 1 turn .. this might cure the problem ..

you can see the screw on this pic

Link Removed
 

Tony Santara

Free Member
Jul 26, 2007
1,372
116
Cheshire (ex Mancunian)
Funster No
17
MH
A class RV
Exp
since 1994
Hi Carol

If Jims remedy doesn't work try contacting Shurflo Europe for an agent

Tel 0044 01293 424000

E-Mail sales@shurflo .co.uk

Link Removed
 
OP
OP
cazd

cazd

Free Member
May 4, 2008
21
0
Shrewsbury
Funster No
2,509
MH
C Class
Exp
New - since August 2008
Hi both

Thanks for your suggestions. We've tried the screw thing apparantly (so the other half says!). I've emailed Shurflo and await a reply when they're back after Xmas....

Many thanks
Carol
 

Join us or log in to post a reply.

To join in you must be a member of MotorhomeFun

Join MotorhomeFun

Join us, it quick and easy!

Log in

Already a member? Log in here.

Funsters who are viewing this thread

Back
Top