Indicator problem

sunboy

Free Member
Nov 17, 2013
13
1
Middlesbrough
Funster No
29,058
MH
Autotrail
Exp
Since2013
Assistance required please. Fiat auto trail Cheyenne 2005.
Near side indicators are on permanently, I.e. Not flashing. I found the problem this morning, might have been like that all night. Not sure as we are on electric hookup on site.
No previous indicator problem but we have had two little issues that have occurred over here in France - radio stopped working and rear step alarm no longer sounds when engine has started and step still out. I thought I could sort these two minor problems out when I got home so not too worried about them but need indicator problem sorting.
Currently just short of Calais and due to travel home Wednesday. Any advice would be most welcome. Cheers in advance. Alan.
 

TheBig1

LIFE MEMBER
Nov 27, 2011
14,600
28,239
Dorset
Funster No
19,048
MH
A class
Exp
many many years! since I was a kid
sounds like the flasher relay has failed, but could also be a short circuit
 
Nov 6, 2013
3,138
122,961
East Sussex
Funster No
28,906
MH
Hymer B574DL
Exp
7 years (tugger for 20)
Assistance required please. Fiat auto trail Cheyenne 2005.
Near side indicators are on permanently, I.e. Not flashing. I found the problem this morning, might have been like that all night. Not sure as we are on electric hookup on site.
No previous indicator problem but we have had two little issues that have occurred over here in France - radio stopped working and rear step alarm no longer sounds when engine has started and step still out. I thought I could sort these two minor problems out when I got home so not too worried about them but need indicator problem sorting.
Currently just short of Calais and due to travel home Wednesday. Any advice would be most welcome. Cheers in advance. Alan.
Hi Sunboy,
Can't shed any light on the indicator problem but I had the same step problem a few months ago.
It turned out to be a fuse in the fuse block beside the engine battery (split relay system?)
Hope this helps(y)
John

Subscribers  do not see these advertisements

 

RS_rob

Free Member
Dec 14, 2013
1,012
667
Turnford
Funster No
29,372
MH
C Class
Exp
over a Year Yay................
Have you tried disconnecting the electric hook up cable & turning off the hab electrics at the main switch aswell as removing the key from the ignition.
 
OP
sunboy

sunboy

Free Member
Nov 17, 2013
13
1
Middlesbrough
Funster No
29,058
MH
Autotrail
Exp
Since2013
Have you tried disconnecting the electric hook up cable & turning off the hab electrics at the main switch aswell as removing the key from the ignition.
Thanks for the info. Followed your recommendations but no joy.
 

RS_rob

Free Member
Dec 14, 2013
1,012
667
Turnford
Funster No
29,372
MH
C Class
Exp
over a Year Yay................
I would systematically go through all the switches as it sounds like a bad earth or cross wired circuit, I had a similar issue the marker lights would glow when outside light was on or an internal light would come on with van lights.
The problem was after maker lights added by previous owner who put the live on 1 circuit & the earth on another.

Subscribers  do not see these advertisements

 
OP
sunboy

sunboy

Free Member
Nov 17, 2013
13
1
Middlesbrough
Funster No
29,058
MH
Autotrail
Exp
Since2013
Hi Sunboy,
Can't shed any light on the indicator problem but I had the same step problem a few months ago.
It turned out to be a fuse in the fuse block beside the engine battery (split relay system?)
Hope this helps(y)
John
 
OP
sunboy

sunboy

Free Member
Nov 17, 2013
13
1
Middlesbrough
Funster No
29,058
MH
Autotrail
Exp
Since2013
Thanks for the info. Will look at the step problem when we are back in Blighty on Wednesday
 
OP
sunboy

sunboy

Free Member
Nov 17, 2013
13
1
Middlesbrough
Funster No
29,058
MH
Autotrail
Exp
Since2013
sounds like the flasher relay has failed, but could also be a short circuit
Managed to source local auto electrician near Calais and goin to see him tomorrow. Thanks anyway for the info

Subscribers  do not see these advertisements

 
OP
sunboy

sunboy

Free Member
Nov 17, 2013
13
1
Middlesbrough
Funster No
29,058
MH
Autotrail
Exp
Since2013
I would systematically go through all the switches as it sounds like a bad earth or cross wired circuit, I had a similar issue the marker lights would glow when outside light was on or an internal light would come on with van lights.
The problem was after maker lights added by previous owner who put the live on 1 circuit & the earth on another.
Cheers. Managed to find where there is a local auto electrician so going to see them first thing tomorrow. Will let u know if I have any joy.
 
OP
sunboy

sunboy

Free Member
Nov 17, 2013
13
1
Middlesbrough
Funster No
29,058
MH
Autotrail
Exp
Since2013
Any Luck ?
Hi All,thanks for your help and advice its great to know help is at hand when things get tricky.
The problem was the m/home alarm,I disconnected the battery and then reconnected it, the alarm went off so I disarmed the alarm with the key fob which in turn switched the alarm off,checked my indicator lights which then flashed then went out,problem solved.
I am not sure what caused the problem might have been the habitation door not shutting correctly ????. No problems since so fingers crossed.
Once again, cheers guys much appreciated.
Now a very happy Sunboy.

Subscribers  do not see these advertisements

 
Top