Help Just plugged in to mains and nothing working | MotorhomeFun | The Motorhome Support and Social Network

Help Just plugged in to mains and nothing working

Christopher Jo

Free Member
Jun 29, 2019
1
0
Bristol
Funster No
62,017
MH
A Class
Exp
Newbie
Hi if anybody has any advice it would be much appreciated. I have just tried to plug in to mains using a new lead and UK plug converter. For the first time since purchasing.
Nothing working inc fridge on 230v.. Everything works fine of batteries and gas.. I've checked main fuse board and cant see any blown. Any help would be appreciated.
 
Feb 24, 2013
11,260
50,547
Bolsover, Derbyshire
Funster No
24,833
MH
Hymer S800
Exp
not long enough
How sure are there is 240V where you are plugged in to?

Are you on a site or home?

Subscribers  do not see these advertisements

 

Puddleduck

LIFE MEMBER
Jan 15, 2014
9,735
21,609
Scottish Borders
Funster No
29,703
MH
SunLiving Lido M45SP
Exp
On and off for many years.
As above.

Also our van has a switch inside the van which cuts off the 240v. Maybe yours is switched off there (if you have such an animal).
 
Feb 10, 2013
508
404
plymouth
Funster No
24,636
MH
Swift bolero
Exp
off and on 30 years
Lead and adapter are new they need testing.

Subscribers  do not see these advertisements

 

Puddleduck

LIFE MEMBER
Jan 15, 2014
9,735
21,609
Scottish Borders
Funster No
29,703
MH
SunLiving Lido M45SP
Exp
On and off for many years.
Some hook up points require lead to be turned in the socket.
Yes, that caught us out first time we came across it.

Also sometimes the power needs to be turned on at the office.

Please let us know when you have it sorted.

Subscribers  do not see these advertisements

 
Safeguard Motorhome Insurance
Rhino Installs
West Country Motorhomes
Johns Cross
Friendly professional service from qualified technicians
Top