Help - battery removal

Discussion in 'Tech/Mech General' started by N Luyetund, Jul 21, 2008.

  1. N Luyetund

    N Luyetund Deleted User

    Ratings:
    +0
    How do I release the + connection on the vehicle battery?

    It's a Fiat 2.3 2006... I've found the quick release on the neg terminal but can't see/find the same on on the pos:Doh:
     
  2. N Luyetund

    N Luyetund Deleted User

    Ratings:
    +0
    Sorted!

    ...there's no quick release, it's a 10mm nut......:Blush:

    Next question, it's been on ehu but hasn't charged the veh batt... should it???
     
  3. American Dream

    American Dream

    Joined:
    Aug 20, 2007
    Messages:
    6,371
    Location:
    Lincoln
    Ratings:
    +156
    In my experience, On EHU, It's normally only the leisure (House) batteries that get charged Graham.
     
  4. N Luyetund

    N Luyetund Deleted User

    Ratings:
    +0
    Thanks Steve

    I'm still confused (more than usual:ROFLMAO:) the switch on the control panel when on 'house' doesn't allow operating the step...

    Yet when switched to veh the step works.... after I disconnected and removed the veh batt...:Doh::Doh:
     
  5. Johns_Cross_Motorhomes

    Johns_Cross_Motorhomes Trader - Motorhome & Accessory Sales

    Joined:
    Jan 5, 2008
    Messages:
    9,527
    Location:
    East Sussex 01-580-881288
    Ratings:
    +7,204
    Hope you have the radio code somewhere as you will have to reinput to make it work.

    Peter
     
  6. American Dream

    American Dream

    Joined:
    Aug 20, 2007
    Messages:
    6,371
    Location:
    Lincoln
    Ratings:
    +156
    That would appear to be A++e about Face.I would have expected the electric step to be connected to the House/Leisure Batteries, as it would drain the Motorhome battery if used constantly while on site.

    Perhaps someone else has experience of this on a similar vehicle?

    The fact it works with the vehicle battery removed while switched to the Vehicle battery!!!! I'm confused as well Graham.:Eeek::Doh:

    Just had a thought....A motorhome we had some time ago DID have Vehicle and Leisure Switches on the control Panel.

    I was under the impression the Vehicle switch only allowed discharge from the battery.Might be worth you reconnecting the Vehicle battery, Putting a multimeter across the Battery and measuring the voltage with the switch off and on.That would prove it.

    Can you post a pic of the unit?
     
    Last edited: Jul 21, 2008
  7. N Luyetund

    N Luyetund Deleted User

    Ratings:
    +0
    Just back from Addenbrookes... (usual congestion on the A14:cry:)

    Batts on charge at the mo...

    Pix... ammeter.... :Doh: far too techie, now, if you'd said hammer....:ROFLMAO:

    Thanks for the help Steve, I'm in no rush to get the van sorted as we won't be going anywhere for a while:cry:
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice