heeeeelllllllllppppppp

Discussion in 'Motorhome Chat' started by bazfergy, Jun 23, 2009.

  1. bazfergy

    bazfergy

    Joined:
    Apr 20, 2009
    Messages:
    566
    Location:
    dumfries scotland
    Ratings:
    +3
    hi guys i have just changed my mh from a burstner nexxo to a pilote galaxy,the problem is it has a solar panel but no instructions it is a sunsaver6. I have charged the leisure battery in the house on a battery charger as it was very low and since putting it on it has lost power again, is it possible the solar panel is draining rather than charging it. Any advice greatly recieved :thumb:
     
  2. vwalan

    vwalan Funster

    Joined:
    Sep 23, 2008
    Messages:
    8,128
    Location:
    roche cornwall
    Ratings:
    +5,372
    there should be one way diodes either in the regulator or built in to the solar panel . have seen some without n they can back feed .
     
  3. Geo

    Geo Trader - Funster

    Joined:
    Jul 29, 2007
    Messages:
    9,974
    Location:
    Mansfield,Notts
    Ratings:
    +9,936
    Why was the battery low in the first place
    your battery is dead,deceased, defuncked of life ,is nomore.:thumb:
    Check that firrst before ripping up solar system
    then check for drains elsewhere
    if you do suspect the solar system, charge battery again and re fit with solar disconected if it goes flat again it aint that
    Geo
     
  4. Scout

    Scout Funster

    Joined:
    Apr 4, 2009
    Messages:
    3,834
    Location:
    doncaster
    Ratings:
    +25,024
    confused? the battery is a dead parrot?

    too much wine methinks:ROFLMAO:
     

Share This Page