Fridge not working on mains electric!

Discussion in 'Fridges & Ovens' started by Abacist, Sep 19, 2018.

  1. Abacist

    Abacist Funster Life Member

    Joined:
    Oct 15, 2013
    Messages:
    1,976
    Location:
    Devon
    Ratings:
    +3,552
    2014 N + B Arto 88F.

    Turned the fridge on at home on EHU on Monday night. Tuesday am fridge showing faults and not working on electric. Set on Auto with only 240 volts available. No faults shown. This morning fridge showing no signs of chilling so put on gas then took wife for medical appointment, then returned and set off using gas. Now on site using gas but not yet done any fault finding about the mains fault. Fridge worked fine on electric a few weeks ago.

    Anyone care to point me in the right direction?
     
  2. Johns_Cross_Motorhomes

    Johns_Cross_Motorhomes Trader - Motorhome & Accessory Sales

    Joined:
    Jan 5, 2008
    Messages:
    9,527
    Location:
    East Sussex 01-580-881288
    Ratings:
    +7,213
    Fuse blown or 240v heater element gone open circuit?

    Peter
     
    • Like it Like it x 2
  3. Abacist

    Abacist Funster Life Member

    Joined:
    Oct 15, 2013
    Messages:
    1,976
    Location:
    Devon
    Ratings:
    +3,552
    All the mains circuit breakers and trip are on which I have just checked. The internal lamps are working when I open the doors of either fridge or freezer but they are likely to be 12 volt powered.

    I shall have to look into the fridge heating element as not encountered that before.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice