Fiat Ducato 2.8jtd won't start

Discussion in 'Fiat' started by Jez and Lin, Sep 5, 2016.

  1. Jez and Lin

    Jez and Lin Funster Life Member

    Joined:
    Dec 26, 2010
    Messages:
    1,028
    Location:
    York, North Yorkshire
    Ratings:
    +2,910
    Currently just south of Rouen, drove down from Calais with no issues yesterday.
    Fired up okay this morning and sort of coughed momentarily then idle speed returned fine.
    I drove off and within 50 yards the engine cut out. Now awaiting recovery. The engine now turns over but won't fire up. Any ideas before the dreaded French mechanic v Englishman with limited mechanical knowledge debate ensues?
     
  2. Jez and Lin

    Jez and Lin Funster Life Member

    Joined:
    Dec 26, 2010
    Messages:
    1,028
    Location:
    York, North Yorkshire
    Ratings:
    +2,910
    Just turned the key and the engine sprang to life for a few seconds and then conked out again. Fuel starvation????
     
  3. mitzimad

    mitzimad Funster

    Joined:
    Jan 28, 2008
    Messages:
    3,813
    Location:
    walthamstow east london
    Ratings:
    +5,583
    sounds like youve self diagnosed most likley problem, not run out of fuel have you ?any fuel leaks? fuse to pump?filter blocked?
     
  4. tonka

    tonka Funster Life Member

    Joined:
    Jul 2, 2008
    Messages:
    6,186
    Location:
    Cannock, Staffs or Benidorm, spain
    Ratings:
    +11,404
    Have you looked at fuel filter ? Know to have issues on the Ducato..
    May be leaking, split hose.. I am no mechanic but worth a quick look for anything obvious..
     
  5. Jez and Lin

    Jez and Lin Funster Life Member

    Joined:
    Dec 26, 2010
    Messages:
    1,028
    Location:
    York, North Yorkshire
    Ratings:
    +2,910
    Thanks, none of the above as far as I'm aware no fuel leaks or smell of diesel!
    Could possibly be split hose allowing air in!
     
    Last edited: Sep 5, 2016
  6. alan

    alan

    Joined:
    Aug 21, 2008
    Messages:
    545
    Location:
    skegness / spain
    Ratings:
    +531
    I had immobiliser problems on mine,check the little lock light is'nt lit up when you switch on ignition.
    Alan
     
    • Thanks Thanks x 1
  7. scotjimland

    scotjimland Funster Life Member

    Joined:
    Jul 25, 2007
    Messages:
    29,094
    Location:
    .
    Ratings:
    +28,350
    Fuel pump was replaced on my 2.8 jtd.. same symptoms
     
  8. Jez and Lin

    Jez and Lin Funster Life Member

    Joined:
    Dec 26, 2010
    Messages:
    1,028
    Location:
    York, North Yorkshire
    Ratings:
    +2,910
    Looking like it could be that
     
  9. Jez and Lin

    Jez and Lin Funster Life Member

    Joined:
    Dec 26, 2010
    Messages:
    1,028
    Location:
    York, North Yorkshire
    Ratings:
    +2,910
    After 36 hours the Garage "thinks" its an ECU problem but will finish diagnosis tomorrow and give me a price.
    Can't help thinking I'M the latest cash cow!!
     
Loading...

Share This Page