Electric Control Panel

Discussion in 'The Beginner' started by Chrisdal, Mar 7, 2009.

  1. Chrisdal

    Chrisdal

    Joined:
    Mar 7, 2009
    Messages:
    3
    Ratings:
    +0
    I am a new MH owner and wondered why the 230v light on my Electric Control Panel is not illuminated when I am hooked up. I appear to have power in the vehicle as I can used mains plug sockets.
     
  2. Jim

    Jim Ringleader

    Joined:
    Jul 19, 2007
    Messages:
    28,355
    Location:
    Sutton on Sea
    Ratings:
    +93,431
    Hi Chrisdal, does the panel have a name on it?

    First Post :thumb: Welcome to motorhome FUN::bigsmile:
     
  3. Tony Lee

    Tony Lee

    Joined:
    Sep 28, 2008
    Messages:
    274
    Ratings:
    +1
    Find the battery charger or converter or whatever you have and make sure it is switched on. Also need the 12V system powered up.
     
  4. Chrisdal

    Chrisdal

    Joined:
    Mar 7, 2009
    Messages:
    3
    Ratings:
    +0
    Hi Jim
    Unfortunately no. It is square brushed aluminium outside and blue indicators. It is on a 2008 Trigano Tribute. It is a common one as I remember seeing them on lots of vans I looked at. I thought it had illuminated previously but this is only the first week of ownership so I cannot be sure.
     
  5. sinbad1

    sinbad1 Deleted User

    Ratings:
    +0
    Does the pannel have a built in tripswitch? if so check it 's not tripped.
     
  6. C.L.S

    C.L.S Trader - Service & Repairs

    Joined:
    Jul 22, 2007
    Messages:
    446
    Ratings:
    +59
    Some of these control panels do not ilimunate , others will iliminate for 30 seconds and then go off , last thing you want lying in bed trying to sleep is the glow of the control panel :Sad:

    Mark
     
Loading...

Share This Page