E495 Reversing Camera Faulty

Discussion in 'Bessacarr' started by yorkist, Jul 5, 2015.

  1. yorkist

    yorkist Read Only Funster

    Joined:
    Jan 10, 2011
    Messages:
    64
    Likes Received:
    35
    Location:
    Altea-Benidorm
    Just buying a 2010 e495 and the seller has disclosed that the reversing cameras are not working. Am I right in thinking I need to go through a Bessacarr dealer to order the part? Or is there a better way if dealing with it? Seems strange both cameras have failed, if they have. All advice appreciated.
     
  2. Larby

    Larby Funster

    Joined:
    Jun 17, 2012
    Messages:
    1,876
    Likes Received:
    4,287
    Location:
    North Essex
    Unlikely both cameras at fault at the same time, is it the monitor?
    Or a fuse?
     
  3. tonka

    tonka Funster Life Member

    Joined:
    Jul 2, 2008
    Messages:
    5,846
    Likes Received:
    8,100
    Location:
    Cannock, Staffs or Benidorm, spain
    And he's not had them fixed ? So hard to solve, hard to get part, cant be bothered..

    Lots of rear view stuff around, just the wiring to figure out if you want to replace it all...
     
  4. Gellyneck

    Gellyneck Funster Life Member

    Joined:
    Jun 5, 2014
    Messages:
    1,873
    Likes Received:
    2,252
    Location:
    Scotland
    Or has the power feed cable to the camera failed?
    Or has the camera output cable become disconnected?
     
  5. ploots

    ploots Funster

    Joined:
    May 31, 2013
    Messages:
    27
    Likes Received:
    11
    Location:
    gloucester
    I would say the power cable has disconnected it keeps happening on our motorhome
     
  6. Bart

    Bart Funster

    Joined:
    Jun 4, 2016
    Messages:
    1,907
    Likes Received:
    560
    Location:
    N.Ireland
    Sikaflex it in place:D2:D2
     
  7. ploots

    ploots Funster

    Joined:
    May 31, 2013
    Messages:
    27
    Likes Received:
    11
    Location:
    gloucester
    It might come to that :D
     
  8. ramsthom

    ramsthom Funster

    Joined:
    Nov 23, 2011
    Messages:
    162
    Likes Received:
    97
    Location:
    durham
    If it a clip on rear view mirror one check the multi pin connecter about 8 inches from the camera. Its normally hidden in the front blinds runner near the rear view mirror. I used to have a 2011 Swift Autocruise and it separated on a few occasions.
     

Share This Page