Dometic freshjet 2200 (1 Viewer)

Duffie

LIFE MEMBER
Oct 25, 2008
191
147
Boroughbridge
Funster No
4,621
MH
Autosleepers topaz
Exp
25+
Hi my air con in my van doesn’t seem to work very well. When I start it up it seems ok then after a short while approx 15 mins it runs warm instead of cold any ideas please I’ve removed the cover inside and cleaned it out so I know it isn’t that
Duffie
 
OP
Duffie

Duffie

LIFE MEMBER
Oct 25, 2008
191
147
Boroughbridge
Funster No
4,621
MH
Autosleepers topaz
Exp
25+
I think your right how do I get to them take the top cover off?

Subscribers  do not see these advertisements

 
Jul 6, 2009
797
993
Funster No
7,383
You don’t state how old the unit is. If it runs for a while then blows warm air could be the filter has become obstructed. Not normally a problem but have known then to fail if a lot of rough roads traveled.
 
OP
Duffie

Duffie

LIFE MEMBER
Oct 25, 2008
191
147
Boroughbridge
Funster No
4,621
MH
Autosleepers topaz
Exp
25+
Sorry I put it in the wrong section initially

Subscribers  do not see these advertisements

 
Jan 19, 2014
7,981
20,040
Derbyshire
Funster No
29,757
MH
Elddis Accordo 105
Exp
since 2014
Sorry I put it in the wrong section initially
Don't worry about that, get on the van roof and check the condenser is giving heat off, the fins need to be clear and the fan needs to be running. The reason I've mentioned this before is If the fan is seized or condenser blocked the AC will cool normally for a few minutes until the condenser gets hot, then the pressures will rise in the system and the inside heat exchanger will get warmer 👍
 

Funsters who are viewing this thread

Top