cab heater A647

Discussion in 'Burstner' started by tattoobluedog12345, Oct 16, 2014.

  1. tattoobluedog12345

    tattoobluedog12345

    Joined:
    Jan 29, 2014
    Messages:
    41
    Location:
    manchester/ winton eccles
    Ratings:
    +3
    just after a bit of advice please. my cab heater stop blowing I have checked I think all the fuses and all ok, just wondering if this could be the resister and if so has anyone done one and is it easy.

    thank you
     
  2. Tootles

    Tootles Funster Deceased RIP

    Joined:
    Sep 14, 2013
    Messages:
    9,513
    Location:
    Lancaster
    Ratings:
    +48,852
    If you can lie down, open the vents, (inside), and see the fan, try moving it with a long screwdriver, or a pencil. If it's stiff, or stuck, that could be your answer, however, are you sure your examining the correct fuse???
     
  3. Al1

    Al1 Funster

    Joined:
    Jul 20, 2008
    Messages:
    46
    Ratings:
    +22
    If it's the resistor pack then it will still work at the highest speed, only the others will be affected.
     
  4. tattoobluedog12345

    tattoobluedog12345

    Joined:
    Jan 29, 2014
    Messages:
    41
    Location:
    manchester/ winton eccles
    Ratings:
    +3
    hi there sorted it now mate , I removed the motor and one of the brushes had broken a bit off jamming it up.
    I cleaned up the motor and flatted the both brushes off nice and toasty now

    thank you
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice