Atwood boiler. | MotorhomeFun | The Motorhome Support and Social Network

Atwood boiler.

Oct 4, 2011
33
37
south west
Funster No
18,371
MH
C class
Exp
off and on since 2000
Having a bit of trouble with the boiler on my rv. The pilot lights but the boiler does not ignite. There is no roaring sounds and it just stays with the flame coming out the end but not power. Any thoughts. Also does anyone know of repair available near Bordeaux
Thanks all
 
Dec 12, 2010
3,428
8,624
Cumbria
Funster No
14,651
MH
C Class
Exp
since 2011
Not familiar with your boiler,but it sounds like the fan which would supply the combustion air isn't running ? This sometimes fails on Truma boilers too, I think the bearings seize up through lack of lube ? Can you get to the fan and see if it can turn freely ?
 
Jul 5, 2013
8,858
8,333
Tunbridge Wells
Funster No
26,797
MH
A class
Exp
Since 2013
Never heard of an Atwood boiler. Is this an American built RV? If so you may well need somebody who specialises in them. They may be rare on the ground in France though.

Subscribers  do not see these advertisements

 
Jan 28, 2008
6,811
8,490
walthamstow east london
Funster No
1,353
MH
renault burstner delphin
Exp
7 years campers before that
have you checked you have power to the unit? if pilot light is a thermocouple type it will light the pilot even with out power last atwood i looked at was 20 years ago they may have changed to flame rectification but yanks tend to be pretty basic
 
OP
jazzijeff
Oct 4, 2011
33
37
south west
Funster No
18,371
MH
C class
Exp
off and on since 2000
Thanks all I will take the burner off tomorrow and clean everything up and try it then and if no joy I’ll panic then 😊
 
Sep 25, 2007
1,072
142
UK
Funster No
399
MH
5th Wheel
Exp
30+
You say the pilot lights but the burner doesn't? I believe that early Atwoods had a pilot light but later ones used electronic ignition. Usually, when you fire the boiler up, you hear quite a solid thump as the gas solenoid valve opens and then multiple clicking of the ignitor (later versions). If you're not getting the thump of the valve, it could be either a stuck valve or poor control to the valve. Have a word with Duncan @ Starspangledspanner. He's a really approachable bloke with good knowledge of these units. he's helped me out with advice a few times. If you find it's a failed control board, Dinosaur Electronics do copy boards and have a VERY good reputation on American RV Forums, they're also a great deal cheaper than Atwood/Suburban.

Subscribers  do not see these advertisements

 
Sep 25, 2007
1,072
142
UK
Funster No
399
MH
5th Wheel
Exp
30+
Nice one mate, chuffed for ya. So does it have a pilot or was that a bit of confusion?
 
OP
jazzijeff
Oct 4, 2011
33
37
south west
Funster No
18,371
MH
C class
Exp
off and on since 2000
Yea it has an electronic sparker type thingamejig. Someone told me the yellow flame suggested it needed more air so it might be the flue. So I stripped it out with that bit of pipe and it did the trick. To be honest I was dead chuffed with myself and immediately had a ice cold beer 😂😂

Subscribers  do not see these advertisements

 
Sep 25, 2007
1,072
142
UK
Funster No
399
MH
5th Wheel
Exp
30+
Yep, sounds right. If you look at the burner tube, you can see a series or a band of oval holes all the way around it. Next to them is a small ( about 5mm) hex head screw. If you loosen this screw and slide the outer tube back and forth, you can adjust the amount of air drawn into the burner tube. You should be getting a nice blue flame and a gentle roar. Pretty sure the Atwood manuals are all online now but if you need a copy, give me a shout and I can scan mine and send it to you.
 
OP
jazzijeff
Oct 4, 2011
33
37
south west
Funster No
18,371
MH
C class
Exp
off and on since 2000
Thanks for the offer I appreciate it. I did find the manual online and there question and answer forum which was useful
 
Nov 22, 2007
6,218
8,645
East Riding of Yorkshire
Funster No
900
MH
Rapido, 999M.
Exp
18+yrs plus 25+Towing
Glad you got it fixed. Back in the Early 90`s I personal imported a Pace Arrow Ellaganza from North Carolina. I had an issue with the Boiler, The problem was "Mud Daubers", It`s a sort of insect? and they build nests from a kind of mud, they had built one in the burner Tube, whilst it had been stored in the USA, prior to export, blocking the tube and causing the problem. They all benefit from a good annual clean.

Subscribers  do not see these advertisements

 
Friendly professional service from qualified technicians
West Country Motorhomes
Rhino Installs
Top