attwood heater

Discussion in 'Motorhome Chat' started by gorsty, Dec 13, 2012.

  1. gorsty

    gorsty

    Joined:
    Aug 17, 2011
    Messages:
    67
    Location:
    uk
    Ratings:
    +22
    Hi Guys
    I have an attwood heater when turned on and it gets up to temp we get water around the base of the heater there is a black box with electric going to it just wondering if any of you guys had come across this problem
    thanks dave [​IMG]


    [​IMG]
     
  2. Terry

    Terry Funster Life Member

    Joined:
    Dec 27, 2007
    Messages:
    10,900
    Location:
    South yorks
    Ratings:
    +7,043
  3. Larrynwin

    Larrynwin Funster

    Joined:
    Feb 22, 2008
    Messages:
    9,360
    Location:
    Norfolk
    Ratings:
    +20,542
    Hi Dave, might be worth a visit to sister site www.rvoc.co.uk dedicated to RVs loads of experience, might come up with an answer for you :thumb:
     
  4. scotjimland

    scotjimland Funster Life Member

    Joined:
    Jul 25, 2007
    Messages:
    29,094
    Location:
    .
    Ratings:
    +28,350
    Two places where it can leak ..

    The drain plug or the safety valve ..

    From your post, it sounds like it's the pressure relief safety valve. Is it leaking more than usual ?

    if so it may have some scale build up on the valve seat.. It can be removed and cleaned.. if still leaking it may need replacing ..

    If it's the drain plug it can be replaced..

    Spares from Duncan at http://www.starspangledspanner.com/

    http://www.starspangledspanner.com/water-heater/cat_31.html

    Have a word with him, he will advise
     
    Last edited: Dec 13, 2012
  5. scotjimland

    scotjimland Funster Life Member

    Joined:
    Jul 25, 2007
    Messages:
    29,094
    Location:
    .
    Ratings:
    +28,350

    Attached Files:

Loading...

Share This Page