x250 oil light.

Discussion in 'Tech/Mech General' started by scottie, Sep 16, 2016.

  1. scottie

    scottie Funster

    Joined:
    Mar 2, 2013
    Messages:
    134
    Likes Received:
    122
    Location:
    chandlers ford
    Hi everyone, some techie help please. I have a 2008 citroen relay conversion, 120 bhp, 2.2 hdi engine. Oil lamp came on at start up but stayed on for about a minute, then whilst on motorway, came on briefly a few times, finally went out. Checked oil level today , was fine. Manual says, that oil could have become degraded, however, full service this Feb, inc oil and filter changes, or so I believe, that's what I paid for. Van only covered about 1000 miles, so far this year, no short journeys. Current mileage 45325 miles. Any ideas, or do I just arrange to have another oil and filter change only and see what happens. Many thanks in advance.
     
  2. scottie

    scottie Funster

    Joined:
    Mar 2, 2013
    Messages:
    134
    Likes Received:
    122
    Location:
    chandlers ford
    Thanks guys, spotted some great stuff by tecnho on a previous thread, sorry, should have looked there first. Now going to have a go at it, fingers crossed.
     
  3. ultima

    ultima Funster

    Joined:
    Mar 24, 2010
    Messages:
    116
    Likes Received:
    37
    Location:
    stoke on trent
    What has been the remedy as I have same van/same problem?
     
  4. dave newell lvs

    dave newell lvs Trader-Vehicle Services

    Joined:
    Oct 31, 2008
    Messages:
    2,515
    Likes Received:
    3,321
    Location:
    Telford, Shropshire
    The oil service indicator in the ECU needs resetting, this can only be done with a diagnostic tool but not one of the cheap EBay readers.

    D.
     
  5. Techno

    Techno Funster Life Member

    Joined:
    Jul 28, 2010
    Messages:
    13,860
    Likes Received:
    14,520
    Location:
    Leeds the one up North
    ?
     
  6. WillH

    WillH Funster

    Joined:
    Feb 9, 2008
    Messages:
    1,618
    Likes Received:
    1,291
    Location:
    SW Scotland
    Does the service indicator not reset after 1000km.?
     
  7. scottie

    scottie Funster

    Joined:
    Mar 2, 2013
    Messages:
    134
    Likes Received:
    122
    Location:
    chandlers ford
    Thanks for your replies everyone.
     
Loading...

Share This Page