Whale underfloor heating problem solving

Discussion in 'Motorhome Accessories' started by ObiVanKenobi, Dec 23, 2013.

  1. ObiVanKenobi

    ObiVanKenobi Read Only Funster

    Joined:
    May 14, 2013
    Messages:
    42
    Likes Received:
    2
    Location:
    St Andrews
    I've got a whale blown air heating system which is mounted under the van, product SH2212(B). The green LED which indicates gas flow is on but only a dull glow and the red LED which helps with fault finding is flashing 5 times.
    The only advice I can find online is the remedy for a gas lock out I.e turning the knob quickly between off and gas - this is not working though. I've had and solved a few gas lock outs before but the green light has never 'glowed' previously. Anyone any suggestions? Currently awaiting a call back from Whale.......
     
  2. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,450
    Likes Received:
    16,882
    Location:
    YO11 2BD
    do all your other gas appliances work properly ?

    are you using propane ? (Red bottle)

    do you have a truma regulator
     
  3. ObiVanKenobi

    ObiVanKenobi Read Only Funster

    Joined:
    May 14, 2013
    Messages:
    42
    Likes Received:
    2
    Location:
    St Andrews
    All gas is working properly, we use LPG Gaslow system and no we don't have a Truman regulator. I've just taken the unit apart, seems as though we have had some water ingress into the unit. Would this possibly cause the system to behave how it is?
     
Loading...

Share This Page