water pump

Discussion in 'Tech/Mech General' started by luckyguy, Sep 14, 2015.

  1. luckyguy

    luckyguy Read Only Funster

    Joined:
    Sep 14, 2015
    Messages:
    5
    Likes Received:
    1
    Location:
    barry angus
    Hi all have an auto-trail 2013 exel 590 ek with a noisy water pump that also pulses.
    Is this normal or can it be fixed only had motorhome for a week. Just want to get
    as much info as possible before going to dealer.Have contacted auto-trail as yet no reply
    Not hope full they will come up with solution.
    All help will be gratefully received.

    all the best luckguy
     
  2. Jim

    Jim Ringleader

    Joined:
    Jul 19, 2007
    Messages:
    25,874
    Likes Received:
    76,311
    Location:
    Sutton on Sea
    It may well have a partial airlock especially if it's been standing and empty for a while. Top up the tank, make sure the water heateer frost valve is not open, then open all the taps and the shower at once and see if it clears. If it doesn't come back here. Meanwhile welcome to the fun. (y)
     
    • Like Like x 1
  3. luckyguy

    luckyguy Read Only Funster

    Joined:
    Sep 14, 2015
    Messages:
    5
    Likes Received:
    1
    Location:
    barry angus
    Thanks jim will try that with luck it will do the trick.
     
  4. PhilandMena

    PhilandMena Funster

    Joined:
    Feb 9, 2008
    Messages:
    2,633
    Likes Received:
    3,648
    Location:
    Corby, Northants
    I too have an Excel (2011) the water system is pressure activated so once your pump is switched on it will start pumping until the right pressure is reached. As Jim say's if you have a tap open (including the webasto boiler anti frost dump valve) the pump will continue to operate even after all the water in the water tank has been emptied. (So switch pump off every time you leave the van). If you get pauses and short bursts of pump activity, it could indicate a leak in the system.
    Best of luck.
     
Loading...

Share This Page