turbo woes maybe

Discussion in 'Motorhome Chat' started by tofo, Mar 4, 2013.

  1. tofo

    tofo Funster

    Joined:
    Oct 1, 2007
    Messages:
    6,582
    Likes Received:
    6,212
    Location:
    Kirby cross further from londin
    my R reg fiat ducato 1.9 td 1998

    first it passed its mot today

    going to the test i noticed a whooshing noise
    like an air leak on inlet manifold but nothing apparent

    test passed thought no more till coming home
    seemed a little slugish hill i would go up in forth
    was a struggle in third

    when the engine failed in 2009
    the coolant run through the exhaust
    to the road

    i was warned that will shorten the life of the turbo
    which is what i think has happened

    should i use a rebuild kit like or similar to this
    http://item.mobileweb.ebay.co.uk/viewitem?itemId=121046584428&cmd=VIDESC

    or obtain an exchange turbo
    if we all think the turbo has failed

    thanks in advance for your replies

    :thumb::thumb::thumb:​
     
  2. joner8888

    joner8888 Read Only Funster

    Joined:
    Jan 4, 2012
    Messages:
    2,190
    Likes Received:
    1,971
    Location:
    somerset
    With a air rushing whoosing sound --have you checked the air pipes in and out of the intercooler ect?
    Sounds like it`s creating pressure but you have a leaky air pipe.
    Turbos usually whine and smoke (like a annoyed woman) when they give up .
     
    • Like Like x 2
  3. Terry

    Terry Funster

    Joined:
    Dec 27, 2007
    Messages:
    10,722
    Likes Received:
    6,224
    Location:
    South yorks
    I also would check the pipes for leaks/splits -No idea on the kit (got to be worth a try :Wink:) new turbo's can run into 500 quid or so :Eeek:
    terry
     
    • Like Like x 1
  4. highwayman

    highwayman Funster Life Member

    Joined:
    Jul 31, 2007
    Messages:
    858
    Likes Received:
    476
    Location:
    Kent coast
    We had the same problem, turbo hose had come off under the top radiator hose.
    I couldn't see it from the front of the vehicle but Sheree spotted it from the side.



    Cheers. Nige
     
    • Like Like x 1
  5. tofo

    tofo Funster

    Joined:
    Oct 1, 2007
    Messages:
    6,582
    Likes Received:
    6,212
    Location:
    Kirby cross further from londin
    Well done sheree correct answer

    Just had a look at the said pipe it was off
    the plastic cable tie gone
    I am assuming that to be the fault
    As there is no smoke at the exhaust
    Only black puffs when reving it and allowing
    it to return to rest

    hose now returned to correct position
    Unable to test run at the moment

    as I hadn't driven it for a while
    It may just of seemed sluggish
    And the extra noise from the intake
    Had me looking for fault

    But your write you dont notice that hose
    Till your pointed towards it

    strange noise though and makes you think
    Oohhherrr that sounds expensive
    Probably me ferreting under the bonnet checking before its test
    Only one advise puncture in drive shaft gaiter
    He said a puncture patch would do it
    But a replacement would be better

    Not sure wether to try a glue on one
    Don't fancy taking the drive shaft out


    Well thanks folks for your replies
    With a bit of luck job done

    Miss Sheree and nige :clap::clap::thanks::thanks::thanks:​
     
    Last edited: Mar 4, 2013
Loading...

Share This Page