Truma Combi 4/6 not firing up

Discussion in 'Heating and Air-Conditioning' started by Gary217, Jun 1, 2016.

  1. Gary217

    Gary217 Funster

    Joined:
    Oct 25, 2015
    Messages:
    162
    Likes Received:
    141
    Location:
    New Forest, UK
    The Truma Combi 4/6 (sorry not sure if 4 or 6) heater/water heater in our La Strada Pronto won't fire up. We have hardly used it in the 7 months we've had the van and it always took up to half a dozen tries before it would run. However, today it won't stay on - I turn it on, it waits, it whirs (fan), it then sounds like it fires up and gives a quiet roar, then a click and it dies.
    I have checked gas is half full so should be pressurised ok, batteries are charged, vents are not blocked.
    As I say, we have hardly used it as we use campsite electricity to heat (fan heater for van; kettle for wash-up water; shower blocks for shower) so it is not a well used item. We're setting off for a fortnight and I'd like the heater to work so I wondered if anyone might have any tips to get it to go. If it's broken big-time I'll get it fixed on return but if there's a little twiddle somewhere then i'd hate to miss that.
    Thanks!
     
  2. Zigisla

    Zigisla Funster

    Joined:
    Oct 24, 2015
    Messages:
    1,007
    Likes Received:
    1,182
    Location:
    Fareham, Hants
    Mine often fires up and then sounds like it clicks off, but is still working. Try leaving it for a while to check.
     
  3. Bill_OR

    Bill_OR Funster

    Joined:
    Dec 11, 2011
    Messages:
    454
    Likes Received:
    572
    Location:
    Nr Hastings, East Sussex
    @Gary217 - have you checked that the thermostat is turned right up?
     
  4. Gary217

    Gary217 Funster

    Joined:
    Oct 25, 2015
    Messages:
    162
    Likes Received:
    141
    Location:
    New Forest, UK
    Thanks Zigisla - I should have said that the on/off dial goes red from orange indicating it has failed to ignite.
     
  5. Gary217

    Gary217 Funster

    Joined:
    Oct 25, 2015
    Messages:
    162
    Likes Received:
    141
    Location:
    New Forest, UK
    Thanks Bill - the only "thermostat" I know of in the van is the dial on the on/off control. Where would a thermostat be (I know...it's an embarrassing question..)?
     
  6. Bill_OR

    Bill_OR Funster

    Joined:
    Dec 11, 2011
    Messages:
    454
    Likes Received:
    572
    Location:
    Nr Hastings, East Sussex
    Sorry Gary - I'm trying to remember how the one on my previous MH worked. However, if the warning light is on then you've got a problem! Does the manual help?
     
  7. Gary217

    Gary217 Funster

    Joined:
    Oct 25, 2015
    Messages:
    162
    Likes Received:
    141
    Location:
    New Forest, UK
    ...the manual says low gas pressure or blocked outlets or seek service help.

    Shame, but we'll get by - if it was working we'd probably not use it as I said earlier, but it does annoy me when things don't work and hot water from the tap for washing up is nice.
     
  8. sdc77

    sdc77 Funster

    Joined:
    Jan 28, 2013
    Messages:
    2,489
    Likes Received:
    2,898
    Location:
    East london
    @Gary217
    Red to orange???
    Red is a gas problem.

    Is it set to gas only (flame symbol)
    Put the other dial in the bottom position .. heating plus water ...
    What happens then?

    Truma controls aide memoire.jpg
     
  9. sdc77

    sdc77 Funster

    Joined:
    Jan 28, 2013
    Messages:
    2,489
    Likes Received:
    2,898
    Location:
    East london
    Grr sorry... reread your post. If it goes solid red then it's gas not igniting (for whatever reason) if the fan you gear sounds a bit unusual then it's almost certainly the distribution fan. Try gas hot water only. If that works then it's that fan.
     
Loading...

Share This Page