Truma 6E

Discussion in 'Heating and Air-Conditioning' started by arthur49, Feb 24, 2010.

  1. arthur49

    arthur49 Read Only Funster

    Joined:
    Oct 24, 2009
    Messages:
    27
    Likes Received:
    0
    Location:
    Perth, Scotland
    Anyone have problems with their Truma 6E? Ours worked great for the 8 or so weeks that we have used the van since we got it new last July.
    Now:-
    1. on either gas or electric, set to provide heat and hot water, after about 10 minutes a very hot smell starts, such that I grabbed an extinguisher and stood over the heater in case of fire! The smell was not a normal 'new' smell ............. and its been used for at least 8 weeks.
    2. on max electric setting 1800W (heating only) the hot air output is pathetic. I've checked all ducts are actually connected to heater and its on winter setting ie recirculating air inlet. Hot air output on gas is excellent.
    Been checked out by our dealer but they found nothing wrong!
    Our confidence in this thing is low.
    Arthur
     
  2. scotjimland

    scotjimland Funster Life Member

    Joined:
    Jul 25, 2007
    Messages:
    28,934
    Likes Received:
    25,574
    Location:
    .
  3. Mastodon

    Mastodon Read Only Funster

    Joined:
    Sep 30, 2007
    Messages:
    16
    Likes Received:
    0
    Our Truma (not sure of the model) is pretty feeble on mains but rorty on gas. Always makes a 'hot' smell when just doing hot water, apparently this is due to the vent fan only running when the heating is on. I've heard of Truma fitting an auxiliary fan to deal with this.
     
  4. arthur49

    arthur49 Read Only Funster

    Joined:
    Oct 24, 2009
    Messages:
    27
    Likes Received:
    0
    Location:
    Perth, Scotland
    Thank you gents - I'm going to speak to Truma direct I think
    Arthur
     
Loading...

Share This Page